aboutsummaryrefslogtreecommitdiff
path: root/source/Target/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/Target/CMakeLists.txt')
-rw-r--r--source/Target/CMakeLists.txt59
1 files changed, 59 insertions, 0 deletions
diff --git a/source/Target/CMakeLists.txt b/source/Target/CMakeLists.txt
new file mode 100644
index 000000000000..f1c2a7e98007
--- /dev/null
+++ b/source/Target/CMakeLists.txt
@@ -0,0 +1,59 @@
+include_directories(../Plugins/Process/Utility)
+
+add_lldb_library(lldbTarget
+ ABI.cpp
+ CPPLanguageRuntime.cpp
+ ExecutionContext.cpp
+ FileAction.cpp
+ JITLoader.cpp
+ JITLoaderList.cpp
+ InstrumentationRuntime.cpp
+ InstrumentationRuntimeStopInfo.cpp
+ Language.cpp
+ LanguageRuntime.cpp
+ Memory.cpp
+ MemoryHistory.cpp
+ ObjCLanguageRuntime.cpp
+ OperatingSystem.cpp
+ PathMappingList.cpp
+ Platform.cpp
+ Process.cpp
+ ProcessInfo.cpp
+ ProcessLaunchInfo.cpp
+ Queue.cpp
+ QueueItem.cpp
+ QueueList.cpp
+ RegisterContext.cpp
+ SectionLoadHistory.cpp
+ SectionLoadList.cpp
+ StackFrame.cpp
+ StackFrameList.cpp
+ StackID.cpp
+ StopInfo.cpp
+ SystemRuntime.cpp
+ Target.cpp
+ TargetList.cpp
+ Thread.cpp
+ ThreadCollection.cpp
+ ThreadList.cpp
+ ThreadPlan.cpp
+ ThreadPlanBase.cpp
+ ThreadPlanCallFunction.cpp
+ ThreadPlanCallFunctionUsingABI.cpp
+ ThreadPlanCallUserExpression.cpp
+ ThreadPlanPython.cpp
+ ThreadPlanRunToAddress.cpp
+ ThreadPlanShouldStopHere.cpp
+ ThreadPlanStepInRange.cpp
+ ThreadPlanStepInstruction.cpp
+ ThreadPlanStepOut.cpp
+ ThreadPlanStepOverBreakpoint.cpp
+ ThreadPlanStepOverRange.cpp
+ ThreadPlanStepRange.cpp
+ ThreadPlanStepThrough.cpp
+ ThreadPlanStepUntil.cpp
+ ThreadPlanTracer.cpp
+ ThreadSpec.cpp
+ UnixSignals.cpp
+ UnwindAssembly.cpp
+ )