aboutsummaryrefslogtreecommitdiff
path: root/source/Utility/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/Utility/CMakeLists.txt')
-rw-r--r--source/Utility/CMakeLists.txt35
1 files changed, 29 insertions, 6 deletions
diff --git a/source/Utility/CMakeLists.txt b/source/Utility/CMakeLists.txt
index 9cddcc02cc58..d4e8e361017c 100644
--- a/source/Utility/CMakeLists.txt
+++ b/source/Utility/CMakeLists.txt
@@ -1,19 +1,42 @@
add_lldb_library(lldbUtility
- ARM_DWARF_Registers.cpp
- ARM64_DWARF_Registers.cpp
- ConvertEnum.cpp
+ Baton.cpp
+ ConstString.cpp
+ DataBufferHeap.cpp
+ DataBufferLLVM.cpp
+ DataEncoder.cpp
+ DataExtractor.cpp
+ Error.cpp
+ FastDemangle.cpp
+ FileSpec.cpp
+ History.cpp
JSON.cpp
LLDBAssert.cpp
- ModuleCache.cpp
+ Log.cpp
+ Logging.cpp
NameMatches.cpp
- PseudoTerminal.cpp
Range.cpp
- RegisterNumber.cpp
+ RegularExpression.cpp
SelectHelper.cpp
SharingPtr.cpp
+ Stream.cpp
+ StreamCallback.cpp
+ StreamGDBRemote.cpp
+ StreamString.cpp
StringExtractor.cpp
StringExtractorGDBRemote.cpp
StringLexer.cpp
+ StringList.cpp
TaskPool.cpp
+ TildeExpressionResolver.cpp
+ UserID.cpp
UriParser.cpp
+ UUID.cpp
+ VASprintf.cpp
+ VMRange.cpp
+
+ LINK_LIBS
+ # lldbUtility cannot have any dependencies
+
+ LINK_COMPONENTS
+ Support
)