aboutsummaryrefslogtreecommitdiff
path: root/sys/contrib/openzfs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sys/contrib/openzfs/Makefile.am')
-rw-r--r--sys/contrib/openzfs/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys/contrib/openzfs/Makefile.am b/sys/contrib/openzfs/Makefile.am
index b409d2196f86..436b78d76282 100644
--- a/sys/contrib/openzfs/Makefile.am
+++ b/sys/contrib/openzfs/Makefile.am
@@ -136,6 +136,13 @@ shellcheck:
echo "skipping shellcheck because shellcheck is not installed"; \
fi
+PHONY += checkabi storeabi
+checkabi: lib
+ $(MAKE) -C lib checkabi
+
+storeabi: lib
+ $(MAKE) -C lib storeabi
+
PHONY += checkbashisms
checkbashisms:
@if type checkbashisms > /dev/null 2>&1; then \
@@ -152,9 +159,10 @@ checkbashisms:
-o -name 'smart' -prune \
-o -name 'paxcheck.sh' -prune \
-o -name 'make_gitrev.sh' -prune \
+ -o -name '90zfs' -prune \
-o -type f ! -name 'config*' \
! -name 'libtool' \
- -exec bash -c 'awk "NR==1 && /\#\!.*bin\/sh.*/ {print FILENAME;}" "{}"' \;); \
+ -exec sh -c 'awk "NR==1 && /\#\!.*bin\/sh.*/ {print FILENAME;}" "{}"' \;); \
else \
echo "skipping checkbashisms because checkbashisms is not installed"; \
fi