aboutsummaryrefslogtreecommitdiff
path: root/test/tsan/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/tsan/CMakeLists.txt')
-rw-r--r--test/tsan/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/tsan/CMakeLists.txt b/test/tsan/CMakeLists.txt
index 5a9542fd76fc..2996c1d80fbd 100644
--- a/test/tsan/CMakeLists.txt
+++ b/test/tsan/CMakeLists.txt
@@ -1,5 +1,7 @@
set(TSAN_TEST_DEPS ${SANITIZER_COMMON_LIT_TEST_DEPS})
-list(APPEND TSAN_TEST_DEPS GotsanRuntimeCheck)
+if(NOT ${LLVM_NATIVE_ARCH} STREQUAL "Mips")
+ list(APPEND TSAN_TEST_DEPS GotsanRuntimeCheck)
+endif()
if(NOT COMPILER_RT_STANDALONE_BUILD)
list(APPEND TSAN_TEST_DEPS tsan)
endif()