aboutsummaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
new file mode 100644
index 000000000000..49af928c3815
--- /dev/null
+++ b/tools/CMakeLists.txt
@@ -0,0 +1,12 @@
+if (CMAKE_SYSTEM_NAME MATCHES "Darwin")
+ add_subdirectory(darwin-debug)
+ add_subdirectory(debugserver)
+endif()
+ add_subdirectory(argdumper)
+ add_subdirectory(driver)
+if (NOT __ANDROID_NDK__)
+ add_subdirectory(lldb-mi)
+endif()
+if (LLDB_CAN_USE_LLDB_SERVER)
+ add_subdirectory(lldb-server)
+endif()