aboutsummaryrefslogtreecommitdiff
path: root/tools/clang-offload-bundler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/clang-offload-bundler/CMakeLists.txt')
-rw-r--r--tools/clang-offload-bundler/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/tools/clang-offload-bundler/CMakeLists.txt b/tools/clang-offload-bundler/CMakeLists.txt
new file mode 100644
index 000000000000..6161d08ae587
--- /dev/null
+++ b/tools/clang-offload-bundler/CMakeLists.txt
@@ -0,0 +1,24 @@
+set(LLVM_LINK_COMPONENTS BitWriter Core Object Support)
+
+if(NOT CLANG_BUILT_STANDALONE)
+ set(tablegen_deps intrinsics_gen)
+endif()
+
+add_clang_executable(clang-offload-bundler
+ ClangOffloadBundler.cpp
+
+ DEPENDS
+ ${tablegen_deps}
+ )
+
+set(CLANG_OFFLOAD_BUNDLER_LIB_DEPS
+ clangBasic
+ )
+
+add_dependencies(clang clang-offload-bundler)
+
+target_link_libraries(clang-offload-bundler
+ ${CLANG_OFFLOAD_BUNDLER_LIB_DEPS}
+ )
+
+install(TARGETS clang-offload-bundler RUNTIME DESTINATION bin)