aboutsummaryrefslogtreecommitdiff
path: root/unittests/Host/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'unittests/Host/CMakeLists.txt')
-rw-r--r--unittests/Host/CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/unittests/Host/CMakeLists.txt b/unittests/Host/CMakeLists.txt
index 4c20f820e3c8..3396f45da4f3 100644
--- a/unittests/Host/CMakeLists.txt
+++ b/unittests/Host/CMakeLists.txt
@@ -1,7 +1,21 @@
-add_lldb_unittest(HostTests
+set (FILES
FileSpecTest.cpp
FileSystemTest.cpp
SocketAddressTest.cpp
SocketTest.cpp
SymbolsTest.cpp
+)
+
+if (CMAKE_SYSTEM_NAME MATCHES "Linux|Android")
+ list(APPEND FILES
+ linux/HostTest.cpp
+ linux/SupportTest.cpp
+ )
+endif()
+
+add_lldb_unittest(HostTests
+ ${FILES}
+ LINK_LIBS
+ lldbCore
+ lldbHost
)