aboutsummaryrefslogtreecommitdiff
path: root/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'util/Makefile.am')
-rw-r--r--util/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/util/Makefile.am b/util/Makefile.am
new file mode 100644
index 000000000000..8f1ba9e9ea98
--- /dev/null
+++ b/util/Makefile.am
@@ -0,0 +1,19 @@
+#AUTOMAKE_OPTIONS = ../ansi2knr no-dependencies
+AUTOMAKE_OPTIONS= ansi2knr
+bin_PROGRAMS= @MAKE_NTPTIME@ @MAKE_TICKADJ@ @MAKE_TIMETRIM@ @MAKE_NTP_KEYGEN@
+EXTRA_PROGRAMS= audio-pcm byteorder hist jitter kern longsize \
+ ntp-keygen ntptime pps-api precision sht testrs6000 tickadj timetrim
+
+INCLUDES= -I$(top_srcdir)/include
+# LDADD might need RESLIB and ADJLIB
+LDADD= ../libntp/libntp.a
+ntp_keygen_LDADD= @LCRYPTO@
+#EXTRA_DIST= README TAGS
+EXTRA_DIST=
+ETAGS_ARGS= Makefile.am
+
+../libntp/libntp.a:
+ cd ../libntp && $(MAKE)
+
+kern.o: kern.c
+ $(COMPILE) -DHAVE_TIMEX_H -c kern.c