aboutsummaryrefslogtreecommitdiff
path: root/utils/check_cfc/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'utils/check_cfc/setup.py')
-rw-r--r--utils/check_cfc/setup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/utils/check_cfc/setup.py b/utils/check_cfc/setup.py
new file mode 100644
index 000000000000..b5fc473639ef
--- /dev/null
+++ b/utils/check_cfc/setup.py
@@ -0,0 +1,21 @@
+"""For use on Windows. Run with:
+ python.exe setup.py py2exe
+ """
+from distutils.core import setup
+try:
+ import py2exe
+except ImportError:
+ import platform
+ import sys
+ if platform.system() == 'Windows':
+ print "Could not find py2exe. Please install then run setup.py py2exe."
+ raise
+ else:
+ print "setup.py only required on Windows."
+ sys.exit(1)
+
+setup(
+ console=['check_cfc.py'],
+ name="Check CFC",
+ description='Check Compile Flow Consistency'
+ )