aboutsummaryrefslogtreecommitdiff
path: root/lib/liblua
Commit message (Collapse)AuthorAgeFilesLines
* contrib/lua: update to 5.4.2Kyle Evans2021-01-142-142/+108
| | | | Merge commit '0ea45b9cd43ce1247eb3eee9bfd5cee3d19068e7' into main
* Fix -Wundef warnings when building libluaAlex Richardson2020-08-251-0/+1
| | | | | | | | | | | | We need to define the LUA_FLOAT_INT64 macro even if we don't use it (copied from stand/luaconf.h). While touching luaconf.h.dist also sync it with the the 5.3.5 release version (matches the one in lib/liblua). Reviewed By: kevans Differential Revision: https://reviews.freebsd.org/D25977 Notes: svn path=/head/; revision=364767
* Properly disable LUA_USE_DLOPEN for bootstrap fluaKyle Evans2020-08-141-0/+2
| | | | | | | | | | | | | | | | | | | | flua does have some specific bits that will include luaconf.h, but the definition of LUA_USE_DLOPEN for those won't matter. This belongs in liblua instead. To expand on my previous commit, which was a little sparse with details, it's not really safe to allow LUA_USE_DLOPEN with host lib paths being used. The host system could have an entirely different lua version and this could cause us to crash and burn. If we want to revive this later, we need to make sure to define c module paths inside OBJDIR that are compiled against whatever version we've bootstrapped. Pointy hat: kevans Notes: svn path=/head/; revision=364227
* flua: don't allow dlopen, et al., for bootstrap fluaKyle Evans2020-08-141-0/+2
| | | | | | | | There are some logistics issues that need to be sorted out here before we can actually allow this to work. Notes: svn path=/head/; revision=364226
* flua: support "require" for binary objects in the base systemEd Maste2020-08-131-0/+1
| | | | | | | | | | Export symbols from flua, and enable dlopen. Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D26059 Notes: svn path=/head/; revision=364222
* flua: initial support for "require" in the base systemEd Maste2020-08-131-3/+3
| | | | | | | | | | | | | | | | | | | | Use /usr not /usr/local for base system components. Use /usr/lib/flua and /usr/share/flua (not lua) for consistency and to avoid the possibility that other software accidentally finds our base system modules. Also drop the version from the path, as flua represents an unspecified lua version that corresponds to the FreeBSD version it comes with. LUA_USE_DLOPEN is not yet enabled because some additional changes are needed wrt symbol visibility. Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D24605 Notes: svn path=/head/; revision=364182
* liblua: ensure that "require" will fail in bootstrap fluaEd Maste2020-04-292-0/+9
| | | | | | | | | | | | | We do not want to support bootstrapping lua modules, so ensure that require will fail by providing a nonexistent path. Reviewed by: kevans MFC after: 1 week Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D24610 Notes: svn path=/head/; revision=360460
* Add an internal liblua and use it in flua.Brooks Davis2020-03-172-0/+824
The new liblua will be used in a forthcoming import of kyua. Reviewed by: kevans Obtained from: CheriBSD Sponsored by: DARPA Differential Revision: https://reviews.freebsd.org/D24090 Notes: svn path=/head/; revision=359045