aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2021-04-12 17:50:55 +0000
committerCy Schubert <cy@FreeBSD.org>2021-04-12 18:23:49 +0000
commit006592a7734cbf82253095281914b2aae4b75ee6 (patch)
treeb487dcc108279919e6a57ee8e0022ba2e0003e1c
parenta52d571aa219f5924c3730754483f0a01eaecb28 (diff)
downloadports-006592a7734cbf82253095281914b2aae4b75ee6.tar.gz
ports-006592a7734cbf82253095281914b2aae4b75ee6.zip
security/wpa_supplicant-devel: Add PASN option
PASN (Pre association Security Negotiation), defined in 802.11az_D1.5, is the mechanism that allows for security association and allow Management Frame Protection (MFP) prior to association. See https://www.spinics.net/lists/hostap/msg06752.html.
-rw-r--r--security/wpa_supplicant-devel/Makefile6
-rw-r--r--security/wpa_supplicant-devel/files/patch-wpa__supplicant_pasn__supplicant.c14
2 files changed, 18 insertions, 2 deletions
diff --git a/security/wpa_supplicant-devel/Makefile b/security/wpa_supplicant-devel/Makefile
index 0c616585e151..c309ea5d394b 100644
--- a/security/wpa_supplicant-devel/Makefile
+++ b/security/wpa_supplicant-devel/Makefile
@@ -43,7 +43,7 @@ OPTIONS_DEFINE= WPS WPS_ER WPS_NOREG WPS_NFC WPS_UPNP PKCS12 SMARTCARD \
IEEE80211R DEBUG_FILE DEBUG_SYSLOG PRIVSEP \
DELAYED_MIC IEEE80211N IEEE80211AC INTERWORKING \
IEEE8021X_EAPOL EAPOL_TEST \
- HS20 NO_ROAMING P2P TDLS DBUS MATCH DOCS \
+ HS20 NO_ROAMING P2P PASN TDLS DBUS MATCH DOCS \
SIM_SIMULATOR USIM_SIMULATOR
OPTIONS_DEFAULT= BSD WIRED \
TLS PEAP TTLS MD5 MSCHAPV2 GTC LEAP OTP PSK \
@@ -77,6 +77,7 @@ INTERWORKING_DESC= Improve ext. network interworking (IEEE 802.11u)
HS20_DESC= Hotspot 2.0
NO_ROAMING_DESC= Disable roaming
P2P_DESC= Peer-to-Peer support
+PASN_DESC= PASN support
TDLS_DESC= Tunneled Direct Link Setup
MATCH_DESC= Interface match mode
@@ -158,7 +159,8 @@ post-patch:
.for simple in WPS WPS_ER WPS_NFC WPS_UPNP PKCS12 SMARTCARD HT_OVERRIDES \
VHT_OVERRIDES TLSV12 IEEE80211AC IEEE80211N IEEE80211R IEEE80211W \
IEEE8021X_EAPOL EAPOL_TEST \
- INTERWORKING DEBUG_FILE DEBUG_SYSLOG HS20 NO_ROAMING PRIVSEP P2P TDLS
+ INTERWORKING DEBUG_FILE DEBUG_SYSLOG HS20 NO_ROAMING PRIVSEP P2P \
+ PASN TDLS
. if ${PORT_OPTIONS:M${simple}}
@${ECHO_CMD} CONFIG_${simple}=y >> ${CFG}
. endif
diff --git a/security/wpa_supplicant-devel/files/patch-wpa__supplicant_pasn__supplicant.c b/security/wpa_supplicant-devel/files/patch-wpa__supplicant_pasn__supplicant.c
new file mode 100644
index 000000000000..f8a71213a120
--- /dev/null
+++ b/security/wpa_supplicant-devel/files/patch-wpa__supplicant_pasn__supplicant.c
@@ -0,0 +1,14 @@
+--- wpa_supplicant/pasn_supplicant.c.orig 2021-04-10 02:48:08.000000000 -0700
++++ wpa_supplicant/pasn_supplicant.c 2021-04-12 10:44:14.939212000 -0700
+@@ -1079,7 +1079,11 @@
+ pasn->group = group;
+ pasn->freq = freq;
+
++#ifdef CONFIG_TESTING_OPTIONS
+ if (wpa_s->conf->force_kdk_derivation ||
++#else
++ if (
++#endif
+ (wpa_s->drv_flags2 & WPA_DRIVER_FLAGS2_SEC_LTF &&
+ ieee802_11_rsnx_capab(beacon_rsnxe, WLAN_RSNX_CAPAB_SECURE_LTF)))
+ pasn->kdk_len = WPA_KDK_MAX_LEN;