aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2021-06-19 20:37:54 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2021-06-22 15:24:37 +0000
commit06e8213fe96f7d5b8049667d303155da66907650 (patch)
tree13d74b126ed4533c83730e6be6c46c5003e02a3a
parentfa0f04a80fb6819eaafd134cc7e88b9b9ec501e6 (diff)
downloadports-06e8213fe96f7d5b8049667d303155da66907650.tar.gz
ports-06e8213fe96f7d5b8049667d303155da66907650.zip
devel/py-qt5-positioning: New port - Provide PyQt5 QtPositioning module
The QtPositioning module contains classes to determine a position by using a variety of possible sources, including satellite, or wifi, or a text file, and so on. That information can then be used to, for example, determine a position on a map. In addition satellite information can be retrieved and area based monitoring can be performed. https://www.riverbankcomputing.com/static/Docs/PyQt5/api/qtpositioning/qtpositioning-module.html Reviewed by: lbartoletti, #portmgr! Approved by: lbartoletti (kde@) Differential Revision: https://reviews.freebsd.org/D30829
-rw-r--r--Mk/Uses/pyqt.mk5
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-qt5-positioning/Makefile28
-rw-r--r--devel/py-qt5-positioning/pkg-descr10
-rw-r--r--devel/py-qt5-positioning/pkg-plist19
-rw-r--r--devel/py-qt5/Makefile4
6 files changed, 65 insertions, 2 deletions
diff --git a/Mk/Uses/pyqt.mk b/Mk/Uses/pyqt.mk
index 0c5c2b4775e0..19410399575b 100644
--- a/Mk/Uses/pyqt.mk
+++ b/Mk/Uses/pyqt.mk
@@ -84,9 +84,11 @@ _USE_PYQT_DEVEL= core dbus dbussupport help location \
designer designerplugin remoteobjects test
_USE_PYQT_GRAPHICS= svg
_USE_PYQT_LANG= qml
+_USE_PYQT_LOCATION= location
_USE_PYQT_MISC= demo
_USE_PYQT_MULTIMEDIA= multimedia multimediawidgets
_USE_PYQT_NET= network networkauth
+_USE_PYQT_POSITIONING= positioning
_USE_PYQT_PRINT= printsupport
_USE_PYQT_TEXTPROC= xml xmlpatterns
_USE_PYQT_WWW= webchannel webengine webkit webkitwidgets websockets
@@ -100,9 +102,11 @@ _USE_PYQT_ALL= ${_USE_PYQT_COMMS} \
${_USE_PYQT_DEVEL} \
${_USE_PYQT_GRAPHICS} \
${_USE_PYQT_LANG} \
+ ${_USE_PYQT_LOCATION} \
${_USE_PYQT_MISC} \
${_USE_PYQT_MULTIMEDIA} \
${_USE_PYQT_NET} \
+ ${_USE_PYQT_POSITIONING} \
${_USE_PYQT_PRINT} \
${_USE_PYQT_TEXTPROC} \
${_USE_PYQT_WWW} \
@@ -159,6 +163,7 @@ py-multimediawidgets_DESC= Python bindings for QtMultimediaWidgets module
py-network_DESC= Python bindings for QtNetwork module
py-networkauth_DESC= Python bindings for QtNetworkAuth module
py-opengl_DESC= Python bindings for QtOpenGL module
+py-positioning_DESC= Python bindings for QtPositioning module
py-printsupport_DESC= Python bindings for Printsupport module
py-qml_DESC= Python bindings for Qml module
py-qscintilla2_DESC= Python bindings for QScintilla2
diff --git a/devel/Makefile b/devel/Makefile
index 4a37f617c125..510475116a5c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5030,6 +5030,7 @@
SUBDIR += py-qt5-designerplugin
SUBDIR += py-qt5-help
SUBDIR += py-qt5-location
+ SUBDIR += py-qt5-positioning
SUBDIR += py-qt5-qscintilla2
SUBDIR += py-qt5-remoteobjects
SUBDIR += py-qt5-sip
diff --git a/devel/py-qt5-positioning/Makefile b/devel/py-qt5-positioning/Makefile
new file mode 100644
index 000000000000..11858be1ad51
--- /dev/null
+++ b/devel/py-qt5-positioning/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= positioning
+CATEGORIES= devel python
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Python bindings for the Qt5 toolkit, QtPositioning module
+
+CONFIGURE_ARGS= --enable QtPositioning
+PYQT_DIST= yes
+
+USES= gl python:3.5+ pyqt:5 qt:5
+USE_GL= gl
+USE_PYQT= sip_build core_run widgets_run
+USE_PYTHON= concurrent flavors py3kplist
+USE_QT= core gui location qmake_build widgets
+
+OPTIONS_DEFINE= API DEBUG
+OPTIONS_DEFAULT=API
+OPTIONS_SUB= yes
+
+API_DESC= Install QtPositioning API for QScintilla2
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${PYQT_APIDIR}
+API_CONFIGURE_OFF= --no-qsci-api
+API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
+DEBUG_CONFIGURE_ON= --debug --trace
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyQt5/QtPositioning.so
+.include <bsd.port.mk>
diff --git a/devel/py-qt5-positioning/pkg-descr b/devel/py-qt5-positioning/pkg-descr
new file mode 100644
index 000000000000..cae7478156e4
--- /dev/null
+++ b/devel/py-qt5-positioning/pkg-descr
@@ -0,0 +1,10 @@
+PyQt5 is a set of Python bindings for Digia's Qt5 application framework.
+This package provides the QtPositioning module.
+
+The QtPositioning module contains classes to determine a position by
+using a variety of possible sources, including satellite, or wifi, or
+a text file, and so on. That information can then be used to, for
+example, determine a position on a map. In addition satellite
+information can be retrieved and area based monitoring can be performed.
+
+WWW: https://riverbankcomputing.com/software/pyqt
diff --git a/devel/py-qt5-positioning/pkg-plist b/devel/py-qt5-positioning/pkg-plist
new file mode 100644
index 000000000000..0fee6b624147
--- /dev/null
+++ b/devel/py-qt5-positioning/pkg-plist
@@ -0,0 +1,19 @@
+%%PYTHON_SITELIBDIR%%/PyQt5/QtPositioning.pyi
+%%PYTHON_SITELIBDIR%%/PyQt5/QtPositioning.so
+%%PYQT_SIPDIR%%/QtPositioning/QtPositioningmod.sip
+%%PYQT_SIPDIR%%/QtPositioning/qgeoaddress.sip
+%%PYQT_SIPDIR%%/QtPositioning/qgeoareamonitorinfo.sip
+%%PYQT_SIPDIR%%/QtPositioning/qgeoareamonitorsource.sip
+%%PYQT_SIPDIR%%/QtPositioning/qgeocircle.sip
+%%PYQT_SIPDIR%%/QtPositioning/qgeocoordinate.sip
+%%PYQT_SIPDIR%%/QtPositioning/qgeolocation.sip
+%%PYQT_SIPDIR%%/QtPositioning/qgeopath.sip
+%%PYQT_SIPDIR%%/QtPositioning/qgeopolygon.sip
+%%PYQT_SIPDIR%%/QtPositioning/qgeopositioninfo.sip
+%%PYQT_SIPDIR%%/QtPositioning/qgeopositioninfosource.sip
+%%PYQT_SIPDIR%%/QtPositioning/qgeorectangle.sip
+%%PYQT_SIPDIR%%/QtPositioning/qgeosatelliteinfo.sip
+%%PYQT_SIPDIR%%/QtPositioning/qgeosatelliteinfosource.sip
+%%PYQT_SIPDIR%%/QtPositioning/qgeoshape.sip
+%%PYQT_SIPDIR%%/QtPositioning/qnmeapositioninfosource.sip
+%%API%%%%PYQT_APIDIR%%/api/python/QtPositioning.api
diff --git a/devel/py-qt5/Makefile b/devel/py-qt5/Makefile
index 43f4fe2819c8..6ba275ce65e6 100644
--- a/devel/py-qt5/Makefile
+++ b/devel/py-qt5/Makefile
@@ -12,8 +12,8 @@ USE_PYTHON= concurrent flavors py3kplist
# Keep these synchronized with _USE_PYQT_ALL in Mk/Use/pyqt.mk
# portedit merge -i -e "OPTIONS_DEFINE=$(make -V _USE_PYQT_ALL:tu | tr '\n' ' ')" .
OPTIONS_DEFINE= CORE CHART DBUS DBUSSUPPORT DEMO DESIGNER DESIGNERPLUGIN \
- GUI HELP MULTIMEDIA MULTIMEDIAWIDGETS NETWORK NETWORKAUTH \
- OPENGL PRINTSUPPORT QML QSCINTILLA2 QUICK QUICKWIDGETS \
+ GUI HELP LOCATION MULTIMEDIA MULTIMEDIAWIDGETS NETWORK NETWORKAUTH \
+ OPENGL POSITIONING PRINTSUPPORT QML QSCINTILLA2 QUICK QUICKWIDGETS \
SENSORS SERIALPORT SQL SVG TEST WEBCHANNEL WEBENGINE \
WEBKIT WEBKITWIDGETS WIDGETS WEBSOCKETS XML XMLPATTERNS \
SIP