aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-04-10 23:47:02 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-04-10 23:50:51 +0000
commit0c6d1e93f93a8af7335b18ea7237b01c0744427b (patch)
treef7ef0d64576545516e2a4463a1d347500e783878
parentfbc665e696d78af040da5a3b0c735d09dd595d9e (diff)
downloadports-0c6d1e93f93a8af7335b18ea7237b01c0744427b.tar.gz
ports-0c6d1e93f93a8af7335b18ea7237b01c0744427b.zip
cad/py-ocp: mark BROKEN
The update to OpenCascade (to 7.5) broke this port, because it relies on all kinds of internals (it's a wrapper, after all). Remove the patching-of-problematic-C++ because that's definitely not needed against current OpenCascade, but the rest of the port is out of my league. Maintainer has been notified.
-rw-r--r--cad/py-ocp/Makefile9
-rw-r--r--cad/py-ocp/files/patch-OCCT_OpenGl__HaltonSampler.hxx11
2 files changed, 3 insertions, 17 deletions
diff --git a/cad/py-ocp/Makefile b/cad/py-ocp/Makefile
index 5b1b821e21bc..f0a6dbbb6137 100644
--- a/cad/py-ocp/Makefile
+++ b/cad/py-ocp/Makefile
@@ -1,6 +1,6 @@
PORTNAME= ocp
DISTVERSION= 7.4-RC2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= cad
# Direct access to github is needed because the release added an extra archive which
# we need to build from, rather than the initial release.
@@ -11,6 +11,8 @@ DISTNAME= OCP_src_Linux
MAINTAINER= ports@nicandneal.net
COMMENT= Python wrapper for OCCT generated using pywrap
+BROKEN= Mismatch between OpenCascase (7.5) and py-ocp (7.4)
+
LICENSE= APACHE20
PATCH_DEPENDS= ${LOCALBASE}/include/OpenCASCADE/OpenGl_HaltonSampler.hxx:cad/opencascade
@@ -33,11 +35,6 @@ USE_PYTHON= flavors
PLIST_FILES= ${PYTHON_SITELIBDIR}/OCP.so
-pre-patch:
-# Copy and patch a header file with a troublesome C++ standard mismatch.
- ${MKDIR} ${OCCT_LOCAL}
- ${CP} ${OCCT}/OpenGl_HaltonSampler.hxx ${OCCT_LOCAL}
-
do-install:
@${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}/
${INSTALL_LIB} ${BUILD_WRKSRC}/OCP.so ${STAGEDIR}${PYTHON_SITELIBDIR}
diff --git a/cad/py-ocp/files/patch-OCCT_OpenGl__HaltonSampler.hxx b/cad/py-ocp/files/patch-OCCT_OpenGl__HaltonSampler.hxx
deleted file mode 100644
index 7fe4fee18e03..000000000000
--- a/cad/py-ocp/files/patch-OCCT_OpenGl__HaltonSampler.hxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- OCCT/OpenGl_HaltonSampler.hxx.orig 2020-06-15 08:29:45 UTC
-+++ OCCT/OpenGl_HaltonSampler.hxx
-@@ -180,7 +180,7 @@ void OpenGl_HaltonSampler::initRandom (Random_number_g
- {
- aPerms[aBase][i] = i;
- }
-- std::random_shuffle (aPerms[aBase].begin(), aPerms[aBase].end(), theRand);
-+ std::shuffle (aPerms[aBase].begin(), aPerms[aBase].end(), theRand);
- }
- initTables (aPerms);
- }