aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-04-07 03:25:10 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-04-07 04:19:54 +0000
commit31bf1886ed9164c5cb36f6717fdb9f0f841d5c84 (patch)
treec1881e1b6bb788f5f6c7faae33dca112c3842551
parent1930871df37d21d1c4773227c1b237b5682c1233 (diff)
downloadports-31bf1886ed9164c5cb36f6717fdb9f0f841d5c84.tar.gz
ports-31bf1886ed9164c5cb36f6717fdb9f0f841d5c84.zip
lang/hermes: Make Python an explicit build dependency (D29353)
This unbreaks the build when using devel/samurai. It previously was available in the configure phase through ninja which has a run dependency on Python. =======================<phase: configure >============================ ===> Missing "/usr/local/bin/python3.7" to create a binary alias at "/wrkdirs/usr/ports/lang/hermes/work/.bin/python" http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-04-04_07h37m38s/logs/errors/hermes-javascript-engine-0.7.2.20210322.log PR: 254678
-rw-r--r--lang/hermes/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/hermes/Makefile b/lang/hermes/Makefile
index baaa2d3c9bba..a28f32dedd6c 100644
--- a/lang/hermes/Makefile
+++ b/lang/hermes/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libicui18n.so:devel/icu
TEST_DEPENDS= googletest>0:devel/googletest \
zip:archivers/zip
-USES= cmake compiler:c++11-lang python:test readline
+USES= cmake compiler:c++11-lang python:build readline
USE_LDCONFIG= yes
USE_GITHUB= yes