aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-18 05:05:07 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-18 05:43:56 +0000
commit680358d7f6c264a2dabd68a14553204fc9cf8daf (patch)
tree83f782baeb9a01aeefb04ee8503514d1ad714648
parent3b115ad1fa10a4644e6b2cd20f534b64f71c0f97 (diff)
downloadports-680358d7f6c264a2dabd68a14553204fc9cf8daf.tar.gz
ports-680358d7f6c264a2dabd68a14553204fc9cf8daf.zip
net/py-geopy: Add AIOHTTP, REQUESTS and TIMEZONE options
-rw-r--r--net/py-geopy/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/net/py-geopy/Makefile b/net/py-geopy/Makefile
index b59e4f5c64a0..5fbde8dcd9ea 100644
--- a/net/py-geopy/Makefile
+++ b/net/py-geopy/Makefile
@@ -23,6 +23,16 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+OPTIONS_DEFINE= AIOHTTP REQUESTS TIMEZONE
+AIOHTTP_DESC= Async HTTP adapter support
+REQUESTS_DESC= Requests adapter support
+TIMEZONE_DESC= Locate timezones
+
+AIOHTTP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>=0:www/py-aiohttp@${PY_FLAVOR}
+REQUESTS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.16.2:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}urllib3>=1.24.2,1:net/py-urllib3@${PY_FLAVOR}
+TIMEZONE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${PY_FLAVOR}
+
do-test:
cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -rs -v