aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-06-18 21:56:23 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-06-18 21:56:23 +0000
commit6df92a09ad7a75d3533ac3510cba668c74689255 (patch)
tree40c286879561bc5d375a0b2b52d62f09f2a51736
parent98807e08be7e890aaaea5710823a192ca318658b (diff)
downloadports-6df92a09ad7a75d3533ac3510cba668c74689255.tar.gz
ports-6df92a09ad7a75d3533ac3510cba668c74689255.zip
biology/biostar-tools: Meta-port for Biostar Handbook tools
Biostar-Tools is a metaport for installing all the tools necessary to work through the Biostar Handbook, except for bedGrapToBigWig, which has license restrictions. If you need bedGraphToBigWig, run cd /usr/ports/biology/ucsc-userapps && make install clean
-rw-r--r--biology/Makefile1
-rw-r--r--biology/biostar-tools/Makefile59
-rw-r--r--biology/biostar-tools/distinfo1
-rwxr-xr-xbiology/biostar-tools/files/biostar-shell.in29
-rw-r--r--biology/biostar-tools/pkg-descr18
-rw-r--r--biology/biostar-tools/pkg-message18
6 files changed, 126 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 4acd54fab965..ec9728ced8ee 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -14,6 +14,7 @@
SUBDIR += biolibc
SUBDIR += bioparser
SUBDIR += biosoup
+ SUBDIR += biostar-tools
SUBDIR += bolt-lmm
SUBDIR += bowtie
SUBDIR += bowtie2
diff --git a/biology/biostar-tools/Makefile b/biology/biostar-tools/Makefile
new file mode 100644
index 000000000000..f9f7023f4ba5
--- /dev/null
+++ b/biology/biostar-tools/Makefile
@@ -0,0 +1,59 @@
+PORTNAME= biostar-tools
+PORTVERSION= 0.9.0
+CATEGORIES= biology python
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Meta-port for Biostar Handbook tools
+
+LICENSE= BSD2CLAUSE
+
+# For a current list see http://data.biostarhandbook.com/install/conda.txt.
+# Also included are some programs not listed above, but mentioned in the text.
+# sra-tools is almost complete and will be added pending testing
+RUN_DEPENDS= wget>0:ftp/wget \
+ curl>0:ftp/curl \
+ nano>0:editors/nano \
+ parallel>0:sysutils/parallel \
+ seqkit>0:biology/seqkit \
+ csvtk>0:science/csvtk \
+ ncbi-entrez-direct>0:biology/ncbi-entrez-direct \
+ readseq>0:biology/readseq \
+ snpeff>0:biology/snpeff \
+ picard-tools>0:biology/picard-tools \
+ bbmap>0:biology/bbmap \
+ minimap2>0:biology/minimap2 \
+ bwa>=0:biology/bwa \
+ bowtie2>=0:biology/bowtie2 \
+ samtools>0:biology/samtools \
+ emboss>0:biology/emboss \
+ bedtools>0:biology/bedtools \
+ bamtools>0:biology/bamtools \
+ ${PYTHON_PKGNAMEPREFIX}cutadapt>0:biology/py-cutadapt@${PY_FLAVOR} \
+ seqtk>0:biology/seqtk \
+ datamash>0:textproc/datamash \
+ bcftools>0:biology/bcftools \
+ subread>0:biology/subread \
+ hisat2>0:biology/hisat2 \
+ trimmomatic>0:biology/trimmomatic \
+ fastqc>0:biology/fastqc \
+ picard-tools>0:biology/picard-tools \
+ ncbi-blast+>0:biology/ncbi-blast+ \
+ cd-hit>0:biology/cd-hit \
+ ${PYTHON_PKGNAMEPREFIX}biopython>0:biology/py-biopython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pysam>0:biology/py-pysam@${PY_FLAVOR} \
+ freebayes>0:biology/freebayes \
+ p5-Net-SSLeay>0:security/p5-Net-SSLeay \
+ bioawk>0:biology/bioawk \
+ vt>0:biology/vt \
+ ${PYTHON_PKGNAMEPREFIX}crossmap>0:biology/py-crossmap@${PY_FLAVOR}
+
+USES= metaport python
+
+SUB_FILES= biostar-shell
+PLIST_FILES= bin/biostar-shell
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/biostar-shell ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/biology/biostar-tools/distinfo b/biology/biostar-tools/distinfo
new file mode 100644
index 000000000000..5eb0b9bcd39d
--- /dev/null
+++ b/biology/biostar-tools/distinfo
@@ -0,0 +1 @@
+TIMESTAMP = 1624053283
diff --git a/biology/biostar-tools/files/biostar-shell.in b/biology/biostar-tools/files/biostar-shell.in
new file mode 100755
index 000000000000..275572a3b6c7
--- /dev/null
+++ b/biology/biostar-tools/files/biostar-shell.in
@@ -0,0 +1,29 @@
+#!/bin/sh -e
+
+ucsc_bin=%%PREFIX%%/userapps/bin
+emboss_bin=%%PREFIX%%/emboss/bin
+cat << EOM
+
+Adding $ucsc_bin and $emboss_bin to \$PATH.
+
+UCSC kent utils and emboss contain commands that conflict with other tools,
+including at least "calc", "mktime", and "stringify".
+
+The other commands with these names may serve entirely different functions
+and will not be accessible while running this shell unless you refer to them
+by their absolute path name (e.g. /usr/local/bin/calc), which is not portable,
+BTW, so don't hard-code such paths into your scripts.
+
+Type "exit" or "Ctrl+D" to return to your normal shell.
+
+EOM
+
+export PATH=${ucsc_bin}:${emboss_bin}:$PATH
+
+# FIXME: Update shell prompts to include (ucsc-kent)?
+
+# Invoke the user's chosen shell
+if echo $SHELL | egrep -q '/t?csh'; then
+ args='-f'
+fi
+exec $SHELL $args
diff --git a/biology/biostar-tools/pkg-descr b/biology/biostar-tools/pkg-descr
new file mode 100644
index 000000000000..104c8bdb5efb
--- /dev/null
+++ b/biology/biostar-tools/pkg-descr
@@ -0,0 +1,18 @@
+Biostar-Tools is a metaport for installing all the tools necessary to work
+through the Biostar Handbook, except for bedGrapToBigWig, which has license
+restrictions. If you need bedGraphToBigWig, run
+
+ cd /usr/ports/biology/ucsc-userapps && make install clean
+
+The handbook instructs the user to install these tools mostly via bioconda,
+which then requires the user to activate the bioconda environment each time
+they want to use the tools. This meta-package installs all of the tools
+except emboss to the default PATH so they just work without any special
+environment. Emboss commands are installed to /usr/local/emboss/bin due to
+conflicts with other packages.
+
+You can also install conda packages on FreeBSD. For details, see
+
+ /usr/ports/sysutils/linux-miniconda-installer/pkg-descr
+
+WWW: https://www.biostarhandbook.com
diff --git a/biology/biostar-tools/pkg-message b/biology/biostar-tools/pkg-message
new file mode 100644
index 000000000000..cd4162b88842
--- /dev/null
+++ b/biology/biostar-tools/pkg-message
@@ -0,0 +1,18 @@
+[
+{ type: install
+ message: <<EOM
+
+If you need bedGraphToBigWig, run:
+
+ cd ${PORTSDIR}/biology/ucsc-userapps && make install clean
+
+sra-tools is using Linux compatibility for now, until the native FreeBSD
+port is complete.
+
+For a quick and proper configuration, run the following:
+
+pkg install -y auto-admin
+auto-install-linux_base
+EOM
+}
+]