aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2021-04-17 05:03:19 +0000
committerThomas Zander <riggs@FreeBSD.org>2021-04-17 05:06:03 +0000
commit7c7c9f42b1d7aa21fe4e32ab49cfc2810bff47e2 (patch)
tree8eb81796df5d44183ca436c9ef1fdbce0b4ba359
parentad086ae1a6c787322c6046f30d4346a69f36097d (diff)
downloadports-7c7c9f42b1d7aa21fe4e32ab49cfc2810bff47e2.tar.gz
ports-7c7c9f42b1d7aa21fe4e32ab49cfc2810bff47e2.zip
audio/openal-soft: Update to upstream version 1.21.0.
PR: 252961 Reported by: fluffy MFH: 2021Q2
-rw-r--r--audio/openal-soft/Makefile5
-rw-r--r--audio/openal-soft/distinfo6
-rw-r--r--audio/openal-soft/files/patch-CMakeLists.txt48
-rw-r--r--audio/openal-soft/pkg-plist3
4 files changed, 29 insertions, 33 deletions
diff --git a/audio/openal-soft/Makefile b/audio/openal-soft/Makefile
index 1a3213fdbd8e..e14ca836e126 100644
--- a/audio/openal-soft/Makefile
+++ b/audio/openal-soft/Makefile
@@ -1,6 +1,5 @@
PORTNAME= openal-soft
-PORTVERSION= 1.20.1
-PORTREVISION= 2
+PORTVERSION= 1.21.0
CATEGORIES= audio
MASTER_SITES= https://openal-soft.org/openal-releases/
@@ -12,7 +11,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libmysofa.so:audio/libmysofa
-USES= cmake compiler:c++11-lang tar:bzip2
+USES= cmake compiler:c++14-lang tar:bzip2
USE_LDCONFIG= yes
CMAKE_ARGS= -DCMAKE_INSTALL_DATADIR:STRING="${PREFIX}/etc"
diff --git a/audio/openal-soft/distinfo b/audio/openal-soft/distinfo
index 46821967b6c2..a65ad7df606d 100644
--- a/audio/openal-soft/distinfo
+++ b/audio/openal-soft/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1579899553
-SHA256 (openal-soft-1.20.1.tar.bz2) = b6ceb051325732c23f5c8b6d37dbd89534517e6439a87e970882b447c3025d6d
-SIZE (openal-soft-1.20.1.tar.bz2) = 512971
+TIMESTAMP = 1611467857
+SHA256 (openal-soft-1.21.0.tar.bz2) = 2916b4fc24e23b0271ce0b3468832ad8b6d8441b1830215b28cc4fee6cc89297
+SIZE (openal-soft-1.21.0.tar.bz2) = 525483
diff --git a/audio/openal-soft/files/patch-CMakeLists.txt b/audio/openal-soft/files/patch-CMakeLists.txt
index 538a685a4e13..59cc59de4b5b 100644
--- a/audio/openal-soft/files/patch-CMakeLists.txt
+++ b/audio/openal-soft/files/patch-CMakeLists.txt
@@ -1,29 +1,25 @@
---- CMakeLists.txt.orig 2020-01-24 07:28:45 UTC
+--- CMakeLists.txt.orig 2020-11-04 10:00:35 UTC
+++ CMakeLists.txt
-@@ -1347,7 +1347,7 @@ endif()
- # Install alsoft.conf configuration file
- IF(ALSOFT_CONFIG)
- INSTALL(FILES alsoftrc.sample
+@@ -1394,19 +1394,19 @@ endif()
+
+ if(ALSOFT_INSTALL_CONFIG)
+ install(FILES alsoftrc.sample
- DESTINATION ${CMAKE_INSTALL_DATADIR}/openal)
+ DESTINATION ${CMAKE_INSTALL_DATADIR}/openal-soft)
- MESSAGE(STATUS "Installing sample configuration")
- MESSAGE(STATUS "")
- ENDIF()
-@@ -1355,7 +1355,7 @@ ENDIF()
- # Install HRTF definitions
- IF(ALSOFT_HRTF_DEFS)
- INSTALL(FILES "hrtf/Default HRTF.mhr"
-- DESTINATION ${CMAKE_INSTALL_DATADIR}/openal/hrtf)
-+ DESTINATION ${CMAKE_INSTALL_DATADIR}/openal-soft/hrtf)
- MESSAGE(STATUS "Installing HRTF definitions")
- MESSAGE(STATUS "")
- ENDIF()
-@@ -1370,7 +1370,7 @@ IF(ALSOFT_AMBDEC_PRESETS)
- presets/rectangle.ambdec
- presets/square.ambdec
- presets/presets.txt
-- DESTINATION ${CMAKE_INSTALL_DATADIR}/openal/presets)
-+ DESTINATION ${CMAKE_INSTALL_DATADIR}/openal-soft/presets)
- MESSAGE(STATUS "Installing AmbDec presets")
- MESSAGE(STATUS "")
- ENDIF()
+ message(STATUS "Installing sample configuration")
+ endif()
+
+ if(ALSOFT_INSTALL_HRTF_DATA)
+ install(DIRECTORY hrtf
+- DESTINATION ${CMAKE_INSTALL_DATADIR}/openal)
++ DESTINATION ${CMAKE_INSTALL_DATADIR}/openal-soft)
+ message(STATUS "Installing HRTF data files")
+ endif()
+
+ if(ALSOFT_INSTALL_AMBDEC_PRESETS)
+ install(DIRECTORY presets
+- DESTINATION ${CMAKE_INSTALL_DATADIR}/openal)
++ DESTINATION ${CMAKE_INSTALL_DATADIR}/openal-soft)
+ message(STATUS "Installing AmbDec presets")
+ endif()
+ message(STATUS "")
diff --git a/audio/openal-soft/pkg-plist b/audio/openal-soft/pkg-plist
index ae0bfbb554a3..08321dfbc00a 100644
--- a/audio/openal-soft/pkg-plist
+++ b/audio/openal-soft/pkg-plist
@@ -1,5 +1,4 @@
%%CONFIG%%bin/alsoft-config
-bin/altonegen
bin/makemhr
bin/openal-info
%%ETCDIR%%/alsoftrc.sample
@@ -23,6 +22,8 @@ lib/libopenal.so
lib/libopenal.so.1
lib/libopenal.so.%%SOVERSION%%
libdata/pkgconfig/openal.pc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/alconvolve.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/alstreamcb.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/alffplay.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/alhrtf.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/allatency.c