aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-05-04 06:25:41 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-05-05 08:29:31 +0000
commitb112172fafc321675b6f822f6cc93b01cd73d10d (patch)
treeba64b8d7d2f5ee03561f942d7ff9d679a5b17f07
parentcf6ea18e37b0d4ab91f1d4da5509a2f166758899 (diff)
downloadports-b112172fafc321675b6f822f6cc93b01cd73d10d.tar.gz
ports-b112172fafc321675b6f822f6cc93b01cd73d10d.zip
net/self-service-password: add missing run dependency
Add www/smarty3 as run dependency While here, pet linters PR: 255554 Reported by: ports@bsdserwis.com (maintainer)
-rw-r--r--net/self-service-password/Makefile16
-rw-r--r--net/self-service-password/files/pkg-message.in8
2 files changed, 15 insertions, 9 deletions
diff --git a/net/self-service-password/Makefile b/net/self-service-password/Makefile
index 0c5adb053a27..d9ba59350c0d 100644
--- a/net/self-service-password/Makefile
+++ b/net/self-service-password/Makefile
@@ -2,6 +2,7 @@
PORTNAME= self-service-password
DISTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= net www
MASTER_SITES= http://ltb-project.org/archives/
PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
@@ -13,20 +14,22 @@ COMMENT= Set of PHP-scripts to change LDAP password over the web
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENCE
+RUN_DEPENDS= ${LOCALBASE}/share/smarty3-${PHP_FLAVOR}/Smarty.class.php:www/smarty3@${PHP_FLAVOR}
+
USES= php:flavors,web
USE_PHP= filter hash ldap mbstring openssl phar session
-NO_BUILD= yes
NO_ARCH= yes
+NO_BUILD= yes
-CFGDIR= conf
-CFGFILE= config.inc.php
+SUB_FILES= pkg-message
+SUB_LIST+= PKGNAME=${PKGNAME}
PLIST_SUB+= SSP_OWN=${WWWOWN}
PLIST_SUB+= SSP_GRP=${WWWGRP}
-SUB_LIST+= PKGNAME=${PKGNAME}
-SUB_FILES= pkg-message
+CFGDIR= conf
+CFGFILE= config.inc.php
.include <bsd.port.pre.mk>
@@ -38,6 +41,9 @@ USE_PHP+= mcrypt
post-extract:
@${FIND} ${WRKSRC}/ -name '*.sig' -delete
@${MV} ${WRKSRC}/${CFGDIR}/${CFGFILE} ${WRKSRC}/${CFGDIR}/${CFGFILE}.sample
+ @${REINPLACE_CMD} \
+ -e 's;/usr/share/php/smarty3;${PREFIX}/share/smarty3-${PHP_FLAVOR};' \
+ ${WRKSRC}/${CFGDIR}/${CFGFILE}.sample
do-install:
@cd ${WRKSRC}/ && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}/
diff --git a/net/self-service-password/files/pkg-message.in b/net/self-service-password/files/pkg-message.in
index fccbd5814d81..8cdd010ea0ac 100644
--- a/net/self-service-password/files/pkg-message.in
+++ b/net/self-service-password/files/pkg-message.in
@@ -5,14 +5,14 @@
%%WWWDIR%%
-Please edit config.inc.php to suit your needs.
+Please edit config.inc.php or create config.inc.local.php to suit your needs.
To make Self Service Password available through your web site, I suggest that
you add something like the following to httpd.conf:
- Alias /ssp/ "%%WWWDIR%%/"
+ Alias /ssp/ "%%WWWDIR%%/htdocs/"
- <Directory "%%WWWDIR%%">
+ <Directory "%%WWWDIR%%/htdocs">
Options none
AllowOverride none
@@ -26,7 +26,7 @@ To make Self Service Password available through your web site, I suggest that
you add something like the following to nginx.conf:
location /ssp/ {
- alias %%WWWDIR%%/;
+ alias %%WWWDIR%%/htdocs/;
index index.php;
location ~ \.php$ {