aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-04-26 11:47:25 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-04-26 14:38:11 +0000
commitc237911a72ac5890045007e7929954a9d48eee96 (patch)
treed65cef5db7bb84293ebbd48759fce94645ff35d4
parent5881daa1d224b60304bee331fb85bf22f332b9ac (diff)
downloadports-c237911a72ac5890045007e7929954a9d48eee96.tar.gz
ports-c237911a72ac5890045007e7929954a9d48eee96.zip
[Qt, GNOME] Handle os-release a little more smartly
Synth -- and therefore not all FreeBSD installations that *could* have an /etc/os-release, or that *ought* to have an os-release file at runtime -- doesn't have the RC script installed, so was triggering the "depend on ports os-release" clause. Partly revert, to checking for existence, but **also** assume that sufficiently-new 13 (or later) releases have os-release in base. This means that 12.2 (which ought to have it) will rely on base, while 12.1 and 11.4 and other legacy releases will rely on the port. PR: 255354 251073
-rw-r--r--devel/qt5-core/Makefile9
-rw-r--r--sysutils/gnome-control-center/Makefile9
2 files changed, 14 insertions, 4 deletions
diff --git a/devel/qt5-core/Makefile b/devel/qt5-core/Makefile
index 5c6214cf3ade..1e4ef798f7bc 100644
--- a/devel/qt5-core/Makefile
+++ b/devel/qt5-core/Makefile
@@ -1,6 +1,6 @@
PORTNAME= core
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel
PKGNAMEPREFIX= qt5-
@@ -39,7 +39,12 @@ QT_CONFIG= glib icu
MORE_WRKSRCS= src/tools/bootstrap src/corelib src/tools/qlalr
.include <bsd.port.pre.mk>
-.if !exists(/etc/rc.d/os-release)
+
+# FreeBSD base gained an os-release in r354922, but that does not exist
+# always (see Synth bug 191, or PR 255354). Be a little more forgiving:
+# assume sufficiently recent base "will have it", and check otherwise
+# because 12.2 does, others like 12.1 do not have it.
+.if !exists(/etc/rc.d/os-release) && (${OSVERSION} < 1300060)
RUN_DEPENDS+= etc_os-release>0:sysutils/etc_os-release
post-patch:
${REINPLACE_CMD} -e '/readEtcFile/s|/etc/os-release|${LOCALBASE}/etc/os-release|g' \
diff --git a/sysutils/gnome-control-center/Makefile b/sysutils/gnome-control-center/Makefile
index 93aea90e1bec..949ed263b96f 100644
--- a/sysutils/gnome-control-center/Makefile
+++ b/sysutils/gnome-control-center/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gnome-control-center
PORTVERSION= 3.38.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome
@@ -73,7 +73,12 @@ LDFLAGS+= -fuse-ld=lld
.endif
.include <bsd.port.pre.mk>
-.if !exists(/etc/rc.d/os-release)
+
+# FreeBSD base gained an os-release in r354922, but that does not exist
+# always (see Synth bug 191, or PR 255354). Be a little more forgiving:
+# assume sufficiently recent base "will have it", and check otherwise
+# because 12.2 does, others like 12.1 do not have it.
+.if !exists(/etc/rc.d/os-release) && (${OSVERSION} < 1300060)
RUN_DEPENDS+= etc_os-release>0:sysutils/etc_os-release
post-patch:
@${REINPLACE_CMD} -e 's|/etc/os-release|${LOCALBASE}/etc/os-release|g' \