aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2021-05-18 05:14:49 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2021-05-18 05:17:36 +0000
commitcb229ba83e23a5a9c8462a23549bc1567d794a66 (patch)
tree32d527dec202d3f9aca6b91e42187c81c65cdb50
parentb850064dedbb50ee64e4398ceae4dd089046132d (diff)
downloadports-cb229ba83e23a5a9c8462a23549bc1567d794a66.tar.gz
ports-cb229ba83e23a5a9c8462a23549bc1567d794a66.zip
New port: audio/pamixer: Console-only mixer for pulseaudio
https://github.com/cdemoulins/pamixer PR: 255761 Reported by: Daniel Menelkir <menelkir@itroll.org> (maintainer)
-rw-r--r--audio/Makefile1
-rw-r--r--audio/pamixer/Makefile23
-rw-r--r--audio/pamixer/distinfo3
-rw-r--r--audio/pamixer/pkg-descr18
4 files changed, 45 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 4575fc20d69b..4a95da7280b5 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -594,6 +594,7 @@
SUBDIR += padthv1-lv2
SUBDIR += paman
SUBDIR += paprefs
+ SUBDIR += pamixer
SUBDIR += pavucontrol
SUBDIR += pavucontrol-qt
SUBDIR += pavumeter
diff --git a/audio/pamixer/Makefile b/audio/pamixer/Makefile
new file mode 100644
index 000000000000..1a4562c42b04
--- /dev/null
+++ b/audio/pamixer/Makefile
@@ -0,0 +1,23 @@
+# Created by: Daniel Menelkir <menelkir@itroll.org>
+
+PORTNAME= pamixer
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.4-15
+DISTVERSIONSUFFIX= -g4ea2594
+CATEGORIES= audio
+
+MAINTAINER= menelkir@itroll.org
+COMMENT= Pulseaudio command line mixer
+
+LICENSE= GPLv3
+
+LIB_DEPENDS+= libpulse.so:audio/pulseaudio \
+ libboost_program_options.so:devel/boost-libs
+
+USES= compiler:gcc-c++11-lib gmake localbase
+USE_GITHUB= yes
+GH_ACCOUNT= cdemoulins
+
+PLIST_FILES= bin/pamixer man/man1/pamixer.1.gz
+
+.include <bsd.port.mk>
diff --git a/audio/pamixer/distinfo b/audio/pamixer/distinfo
new file mode 100644
index 000000000000..83d99ee9a88a
--- /dev/null
+++ b/audio/pamixer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1620727132
+SHA256 (cdemoulins-pamixer-v1.4-15-g4ea2594_GH0.tar.gz) = eaf1d04e9369b59ae14663ee4cb0c4186b199e8ac35ccbe361a01ff2be15c32d
+SIZE (cdemoulins-pamixer-v1.4-15-g4ea2594_GH0.tar.gz) = 18374
diff --git a/audio/pamixer/pkg-descr b/audio/pamixer/pkg-descr
new file mode 100644
index 000000000000..bfb776b6dc24
--- /dev/null
+++ b/audio/pamixer/pkg-descr
@@ -0,0 +1,18 @@
+Pulseaudio command line mixer.
+
+pamixer is like amixer but for pulseaudio. It can control the
+volume levels of the sinks. Also, this project can provide you
+a small C++ library to control pulseaudio.
+
+Features
+ - Get the current volume of the default sink, the default
+ source or a selected one by his id
+ - Set the volume for the default sink, the default
+ source or any other device
+ - List the sinks
+ - List the sources
+ - Increase / Decrease the volume for a device (using gamma
+ correction optionally)
+ - Mute or unmute a device
+
+WWW: https://github.com/cdemoulins/pamixer