aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-04-13 13:19:46 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-04-13 13:19:46 +0000
commitf67c7d2ee52f4f062b4a18e8ab17bc8f3d0c2fdc (patch)
tree2703d50f823a53b28bfb3d70c977ceb9e2db3ba2
parent48de6fdcb814d82b5c7456099145cd6c9e202107 (diff)
downloadports-f67c7d2ee52f4f062b4a18e8ab17bc8f3d0c2fdc.tar.gz
ports-f67c7d2ee52f4f062b4a18e8ab17bc8f3d0c2fdc.zip
lang/gcc9-devel: enable on powerpc64le
-rw-r--r--lang/gcc9-devel/Makefile2
-rw-r--r--lang/gcc9-devel/files/patch-libcpp_lex.c25
2 files changed, 26 insertions, 1 deletions
diff --git a/lang/gcc9-devel/Makefile b/lang/gcc9-devel/Makefile
index 4e4ee03ee4ee..93e5a8cef971 100644
--- a/lang/gcc9-devel/Makefile
+++ b/lang/gcc9-devel/Makefile
@@ -13,7 +13,7 @@ COMMENT= GNU Compiler Collection 9
LICENSE= GPLv3 GPLv3RLE
LICENSE_COMB= multi
-ONLY_FOR_ARCHS= aarch64 amd64 arm armv6 armv7 i386 powerpc powerpc64 sparc64
+ONLY_FOR_ARCHS= aarch64 amd64 arm armv6 armv7 i386 powerpc powerpc64 powerpc64le sparc64
LIB_DEPENDS= libgmp.so:math/gmp \
libmpfr.so:math/mpfr \
diff --git a/lang/gcc9-devel/files/patch-libcpp_lex.c b/lang/gcc9-devel/files/patch-libcpp_lex.c
new file mode 100644
index 000000000000..05ad28872d11
--- /dev/null
+++ b/lang/gcc9-devel/files/patch-libcpp_lex.c
@@ -0,0 +1,25 @@
+This is
+
+ commit cd547f0ddcd3a54e5b73bcda5ac0f0c46808db8b
+ Author: Jakub Jelinek <jakub@redhat.com>
+ Date: Sat Sep 26 10:07:41 2020 +0200
+
+which is on the GCC 10 release branch and thus part of lang/gcc10-devel;
+we should automatically get it with GCC 10.3.
+
+--- libcpp/lex.c.orig 2020-11-02 10:24:50 UTC
++++ libcpp/lex.c
+@@ -531,11 +531,11 @@ init_vectorized_lexer (void)
+ search_line_fast = impl;
+ }
+
+-#elif defined(_ARCH_PWR8) && defined(__ALTIVEC__)
++#elif (GCC_VERSION >= 4005) && defined(_ARCH_PWR8) && defined(__ALTIVEC__)
+
+ /* A vection of the fast scanner using AltiVec vectorized byte compares
+ and VSX unaligned loads (when VSX is available). This is otherwise
+- the same as the pre-GCC 5 version. */
++ the same as the AltiVec version. */
+
+ ATTRIBUTE_NO_SANITIZE_UNDEFINED
+ static const uchar *