aboutsummaryrefslogtreecommitdiff
path: root/games/flightgear/Makefile
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2019-05-29 15:45:06 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2019-05-29 15:45:06 +0000
commit0a640d65f7400e85d9654ab8cddb8d92bd71f3c1 (patch)
treeb6b3c4985224063d73c998ae77afb60715eb34fc /games/flightgear/Makefile
parent844a352a9fc7d9a40ddfbf19db637215b97f283c (diff)
downloadports-0a640d65f7400e85d9654ab8cddb8d92bd71f3c1.tar.gz
ports-0a640d65f7400e85d9654ab8cddb8d92bd71f3c1.zip
Re-enable EVENT_INPUT support on 13-CURRENT
Patch has been accepted upstream, see: https://sourceforge.net/p/flightgear/flightgear/merge-requests/165/ so we use it as a backport, waiting for next Flightgear version. PR: 237835 Submitted by: Aaron Farias <timido@ubuntu.com>
Notes
Notes: svn path=/head/; revision=502969
Diffstat (limited to 'games/flightgear/Makefile')
-rw-r--r--games/flightgear/Makefile18
1 files changed, 4 insertions, 14 deletions
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index d8c878476753..75956cc0fe1e 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -3,7 +3,7 @@
PORTNAME= flightgear
PORTVERSION= 2018.3.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SF/flightgear/release-${PORTVERSION:R}
@@ -22,7 +22,8 @@ LIB_DEPENDS= libpng.so:graphics/png \
libcurl.so:ftp/curl \
libudev.so:devel/libudev-devd
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:x11-toolkits/plib \
- ${LOCALBASE}/lib/libSimGearCore.a:devel/simgear
+ ${LOCALBASE}/lib/libSimGearCore.a:devel/simgear \
+ ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:x11-toolkits/plib \
${LOCALBASE}/lib/libSimGearCore.a:devel/simgear \
${LOCALBASE}/share/flightgear/version:games/flightgear-data
@@ -59,15 +60,4 @@ post-patch:
@${REINPLACE_CMD} -Ei .c++20 '/file|set_prop/s/version[[:>:]]/&.txt/' \
${WRKSRC}/CMakeLists.txt
-.include <bsd.port.pre.mk>
-
-# XXX Disable EVENT_INPUT on 13-CURRENT to avoid crashing during startup
-# See: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=237835
-# and: https://svnweb.freebsd.org/base?view=revision&revision=340387
-.if ${OSVERSION} >= 1300003
-CMAKE_ARGS+= -DEVENT_INPUT:BOOL=OFF
-.else
-BUILD_DEPENDS+= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>