aboutsummaryrefslogtreecommitdiff
path: root/games/flightgear/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-03-06 08:21:36 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-03-06 08:21:36 +0000
commit75a8d8568dbe0bda3f2671a019710dd4c0b86e27 (patch)
tree1efaad6aee5ae1913e8e1497f50abdc474c86ce5 /games/flightgear/Makefile
parent0be9a6a12a4b93d76d7dff5911d7f6b77eba9ab4 (diff)
downloadports-75a8d8568dbe0bda3f2671a019710dd4c0b86e27.tar.gz
ports-75a8d8568dbe0bda3f2671a019710dd4c0b86e27.zip
games/flightgear: unbreak with libc++ 8
In file included from utils/fgelev/fgelev.cxx:23: In file included from /usr/include/c++/v1/iostream:38: In file included from /usr/include/c++/v1/ios:216: In file included from /usr/include/c++/v1/__locale:15: In file included from /usr/include/c++/v1/string:505: In file included from /usr/include/c++/v1/string_view:176: In file included from /usr/include/c++/v1/__string:57: In file included from /usr/include/c++/v1/algorithm:640: In file included from /usr/include/c++/v1/initializer_list:47: In file included from /usr/include/c++/v1/cstddef:38: version:1:1: error: expected unqualified-id 2018.3.2 ^ PR: 236192 Reported by: pkg-fallout Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=494783
Diffstat (limited to 'games/flightgear/Makefile')
-rw-r--r--games/flightgear/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index eb6a113e2c85..c3fddc14a417 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -52,4 +52,10 @@ QT5_CMAKE_OFF= -DENABLE_QT:BOOL=OFF
QT5_USES= qt:5
QT5_USE= QT=core,buildtools,gui,declarative,network,qmake,widgets,svg
+post-patch:
+# Avoid conflict with C++20 <version> by adding .txt suffix
+ @${MV} ${WRKSRC}/version ${WRKSRC}/version.txt
+ @${REINPLACE_CMD} -Ei .c++20 '/file|set_prop/s/version[[:>:]]/&.txt/' \
+ ${WRKSRC}/CMakeLists.txt
+
.include <bsd.port.mk>