aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-05-22 10:52:03 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-05-22 11:04:08 +0000
commit4032ee7347316232dd682310b7d9533a520a35d7 (patch)
tree0072300bc9238c0c7e1ca51037cee077867476dc /graphics
parentef0c7ddce0b18552743aaba4f13167826182a349 (diff)
downloadports-4032ee7347316232dd682310b7d9533a520a35d7.tar.gz
ports-4032ee7347316232dd682310b7d9533a520a35d7.zip
graphics/py-pytesseract: NEW wrapper for tesseract
Python-tesseract is an optical character recognition (OCR) tool for python. That is, it will recognize and “read” the text embedded in images. Python-tesseract is a wrapper for Google’s Tesseract-OCR Engine. It is also useful as a stand-alone invocation script to tesseract, as it can read all image types supported by the Pillow and Leptonica imaging libraries, including jpeg, png, gif, bmp, tiff, and others. Additionally, if used as a script, Python-tesseract will print the recognized text instead of writing it to a file.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-pytesseract/Makefile21
-rw-r--r--graphics/py-pytesseract/distinfo3
-rw-r--r--graphics/py-pytesseract/pkg-descr11
3 files changed, 35 insertions, 0 deletions
diff --git a/graphics/py-pytesseract/Makefile b/graphics/py-pytesseract/Makefile
new file mode 100644
index 000000000000..ade2595f0a60
--- /dev/null
+++ b/graphics/py-pytesseract/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= pytesseract
+PORTVERSION= 0.3.7
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= mandree@FreeBSD.org
+COMMENT= wrapper for Google's Tesseract OCR engine
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= tesseract:graphics/tesseract
+
+USES= localbase python:3.4+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-pytesseract/distinfo b/graphics/py-pytesseract/distinfo
new file mode 100644
index 000000000000..89b8c53ece6e
--- /dev/null
+++ b/graphics/py-pytesseract/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1621679287
+SHA256 (pytesseract-0.3.7.tar.gz) = 4ecfc898d00a70fcc38d2bce729de1597c67e7bc5d2fa26094714c9f5b573645
+SIZE (pytesseract-0.3.7.tar.gz) = 13715
diff --git a/graphics/py-pytesseract/pkg-descr b/graphics/py-pytesseract/pkg-descr
new file mode 100644
index 000000000000..dcc091b3b990
--- /dev/null
+++ b/graphics/py-pytesseract/pkg-descr
@@ -0,0 +1,11 @@
+Python-tesseract is an optical character recognition (OCR) tool for python.
+That is, it will recognize and “read” the text embedded in images.
+
+Python-tesseract is a wrapper for Google’s Tesseract-OCR Engine. It is also
+useful as a stand-alone invocation script to tesseract, as it can read all
+image types supported by the Pillow and Leptonica imaging libraries, including
+jpeg, png, gif, bmp, tiff, and others. Additionally, if used as a script,
+Python-tesseract will print the recognized text instead of writing it to a
+file.
+
+WWW: https://github.com/madmaze/pytesseract