aboutsummaryrefslogtreecommitdiff
path: root/lang/rust-bootstrap/Makefile
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-05-11 16:56:40 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-05-11 17:29:32 +0000
commitd50822c34fe1d8adf879745d2b26c000af2e8862 (patch)
treee15ead3d98a071fea35084150b2c3d0a5826136d /lang/rust-bootstrap/Makefile
parent59c77d251295f133d60f6e8034f0ed722ad6f916 (diff)
downloadports-d50822c34fe1d8adf879745d2b26c000af2e8862.tar.gz
ports-d50822c34fe1d8adf879745d2b26c000af2e8862.zip
lang/rust, lang/rust-bootstrap: Simplify makesum
Diffstat (limited to 'lang/rust-bootstrap/Makefile')
-rw-r--r--lang/rust-bootstrap/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/lang/rust-bootstrap/Makefile b/lang/rust-bootstrap/Makefile
index 9f1bb4afaaec..797637e9bead 100644
--- a/lang/rust-bootstrap/Makefile
+++ b/lang/rust-bootstrap/Makefile
@@ -127,6 +127,11 @@ IGNORE= will not build on 12.x due to old system
EXTRA_PATCHES+= ${PATCHDIR}/${FLAVOR:S/_/-/}
.endif
+.if make(makesum)
+DISTFILES:= ${DISTFILES:M*\:rust} \
+ ${FLAVORS:O:@_flavor@${:!${SETENV} FLAVOR=${_flavor} ${MAKE} -V'DISTFILES:N*\:rust'!}@}
+.endif
+
post-patch:
# Disable vendor checksums
@${REINPLACE_CMD} 's,"files":{[^}]*},"files":{},' \
@@ -238,16 +243,4 @@ do-install:
@cd ${STAGEDIR}${PREFIX} && \
${FIND} rust-bootstrap -type f >> ${TMPPLIST}
-.if !defined(_RUST_MAKESUM_GUARD)
-makesum:
- ${MAKE} -D_RUST_MAKESUM_GUARD makesum FLAVOR=${FLAVORS:O:[1]} DISTINFO_FILE=${DISTINFO_FILE}.tmp
-.for _flavor in ${FLAVORS:O:[2..-1]}
- ${MAKE} -D_RUST_MAKESUM_GUARD makesum FLAVOR=${_flavor} DISTINFO_FILE=${DISTINFO_FILE}.${_flavor}
- ${SED} 1d ${DISTINFO_FILE}.${_flavor} >> ${DISTINFO_FILE}.tmp
- ${RM} ${DISTINFO_FILE}.${_flavor}
-.endfor
- ${AWK} '!seen[$$0]++' ${DISTINFO_FILE}.tmp > ${DISTINFO_FILE}
- ${RM} ${DISTINFO_FILE}.tmp
-.endif
-
.include <bsd.port.post.mk>