aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg-devel/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2022-01-20 08:22:47 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2022-01-20 09:28:54 +0000
commit08342c9812d72301a3eba7b49f79c331ab708db5 (patch)
treee30258a20a634ee2462f0cea2470a8ccd7a2995f /ports-mgmt/pkg-devel/Makefile
parent696a89a3ba4fa7f2e4705c9d431f06de294f07e3 (diff)
downloadports-08342c9812d72301a3eba7b49f79c331ab708db5.tar.gz
ports-08342c9812d72301a3eba7b49f79c331ab708db5.zip
ports-mgmt/pkg-*: fix symbol collisions
while we fixed the symbol collision between libmd and libcrypto long ago in dynamic linked program, the collision is still there somehow for statically build programs. The manual check for liblzma_libs for static linking that was added long ago brings in a link to libmd before a link to libcrypto (this is since FreeBSD 13.0+ This manual check is not necessary anymore anyway, so let's drop it. Reported by: Franco Fitchner (from Opnsense)
Diffstat (limited to 'ports-mgmt/pkg-devel/Makefile')
-rw-r--r--ports-mgmt/pkg-devel/Makefile12
1 files changed, 1 insertions, 11 deletions
diff --git a/ports-mgmt/pkg-devel/Makefile b/ports-mgmt/pkg-devel/Makefile
index 580d876d9193..2beaad8d5d37 100644
--- a/ports-mgmt/pkg-devel/Makefile
+++ b/ports-mgmt/pkg-devel/Makefile
@@ -1,5 +1,6 @@
PORTNAME= pkg
DISTVERSION= 1.17.99.9
+PORTREVISION= 1
_PKG_VERSION= ${DISTVERSION}
CATEGORIES= ports-mgmt
PKGNAMESUFFIX= -devel
@@ -43,13 +44,6 @@ CONFIGURE_ARGS+= --with-asan --with-ubsan
#CONFIGURE_ARGS+= --default-format=tzst
#.endif
-.if !exists(/usr/libdata/pkgconfig/liblzma.pc)
-LIBLZMA_LIBS= -llzma
-.else
-LIBLZMA_PC!= ${EGREP} ^Libs /usr/libdata/pkgconfig/liblzma.pc
-LIBLZMA_LIBS= ${LIBLZMA_PC:M-l*}
-.endif
-
.if defined(WITH_PKG)
.if ${WITH_PKG} != devel
. if !defined(PACKAGE_BUILDING)
@@ -67,10 +61,6 @@ PKG_DEPENDS=
PKG_BIN= ${WRKSRC}/src/pkg-static
.endif
-post-patch:
- ${REINPLACE_CMD} -e "s|-llzma|${LIBLZMA_LIBS}|g" ${WRKSRC}/auto.def \
- ${WRKSRC}/src/Makefile.autosetup ${WRKSRC}/tests/Makefile.autosetup
-
.if ${PORT_OPTIONS:MSAN}
post-build:
@(cd ${WRKSRC}/src && \