aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-03-16 16:35:12 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-03-16 16:35:12 +0000
commitef5cf97f57765c25f88948e381fd65818558314e (patch)
tree8c3249fe87e825367fca7503b02f3b23ae143f09 /x11-toolkits
parent41118d8d88292c5185e01995c10bbdbda2678f14 (diff)
downloadports-ef5cf97f57765c25f88948e381fd65818558314e.tar.gz
ports-ef5cf97f57765c25f88948e381fd65818558314e.zip
x11-toolkits/gtk30: depend on gsettings-desktop-schemas
Gtk on Wayland uses gsettings to get cursor theme but without schemes installed it falls back to "default" theme which doesn't exist. $ gsettings get org.gnome.desktop.interface cursor-theme No such schema “org.gnome.desktop.interface” $ MOZ_ENABLE_WAYLAND=1 firefox [...] Gdk-Message: 15:15:20.123: Unable to load hand2 from the cursor theme Gdk-Message: 15:15:20.300: Unable to load hand2 from the cursor theme Gdk-Message: 15:15:20.536: Unable to load hand2 from the cursor theme Gdk-Message: 15:15:52.250: Unable to load hand2 from the cursor theme Gdk-Message: 15:15:52.350: Unable to load hand2 from the cursor theme Gdk-Message: 15:15:52.834: Unable to load hand2 from the cursor theme Gdk-Message: 15:15:52.933: Unable to load hand2 from the cursor theme $ emacs -Q # --with-pgtk Gdk-Message: 15:16:34.736: Unable to load sb_v_double_arrow from the cursor theme Gdk-Message: 15:16:34.736: Unable to load sb_h_double_arrow from the cursor theme Gdk-Message: 15:16:35.272: Unable to load hand2 from the cursor theme Gdk-Message: 15:16:35.272: Unable to load sb_h_double_arrow from the cursor theme Gdk-Message: 15:16:35.272: Unable to load sb_v_double_arrow from the cursor theme $ truss emacs -Q 2>&1 | fgrep /cursor [...] open("/home/foo/.icons/default/cursors/",O_RDONLY|O_NONBLOCK|O_DIRECTORY|O_CLOEXEC,00) ERR#2 'No such file or directory' open("/usr/share/icons/default/cursors/",O_RDONLY|O_NONBLOCK|O_DIRECTORY|O_CLOEXEC,00) ERR#2 'No such file or directory' open("/usr/share/pixmaps/default/cursors/",O_RDONLY|O_NONBLOCK|O_DIRECTORY|O_CLOEXEC,00) ERR#2 'No such file or directory' open("/home/foo/.cursors/default/cursors/",O_RDONLY|O_NONBLOCK|O_DIRECTORY|O_CLOEXEC,00) ERR#2 'No such file or directory' open("/usr/share/cursors/xorg-x11/default/cursors/",O_RDONLY|O_NONBLOCK|O_DIRECTORY|O_CLOEXEC,00) ERR#2 'No such file or directory' open("/usr/local/share/icons/default/cursors/",O_RDONLY|O_NONBLOCK|O_DIRECTORY|O_CLOEXEC,00) ERR#2 'No such file or directory' [...] PR: 253742 Submitted by: Evgeniy Khramtsov <2khramtsov@gmail.com>
Notes
Notes: svn path=/head/; revision=568579
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gtk30/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index b44a95d434d4..96fae8a6409c 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -5,6 +5,7 @@
PORTNAME= gtk
PORTVERSION= 3.24.24
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME/sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
PKGNAMESUFFIX= 3
@@ -81,7 +82,8 @@ WAYLAND_CONFIGURE_ENABLE= wayland-backend
WAYLAND_BUILD_DEPENDS= wayland-protocols>=0:graphics/wayland-protocols
WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland \
libxkbcommon.so:x11/libxkbcommon
-WAYLAND_RUN_DEPENDS= wayland-protocols>=0:graphics/wayland-protocols
+WAYLAND_RUN_DEPENDS= gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas \
+ wayland-protocols>=0:graphics/wayland-protocols
WAYLAND_USES= gl
WAYLAND_USE= GL=egl