aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/nss/Makefile2
-rw-r--r--security/nss/files/patch-lib-freebl-Makefile21
2 files changed, 18 insertions, 5 deletions
diff --git a/security/nss/Makefile b/security/nss/Makefile
index a45b69fc728a..a4f17aa15548 100644
--- a/security/nss/Makefile
+++ b/security/nss/Makefile
@@ -67,7 +67,7 @@ MAKE_ENV+= NSS_DISABLE_ARM32_NEON=1
EXTRA_PATCHES= ${FILESDIR}/${ARCH}${PPC_ABI:tl}-lib_freebl_scripts_gen.sh
USES+= compiler:c++11-lang # -mcrypto -mvsx
.if ! ${PORT_OPTIONS:MVSX}
-MAKE_ENV+= NSS_DISABLE_ALTIVEC=1
+MAKE_ENV+= NSS_DISABLE_CRYPTO_VSX=1
.endif
.endif
diff --git a/security/nss/files/patch-lib-freebl-Makefile b/security/nss/files/patch-lib-freebl-Makefile
index b42174292849..f9e412e534f5 100644
--- a/security/nss/files/patch-lib-freebl-Makefile
+++ b/security/nss/files/patch-lib-freebl-Makefile
@@ -1,11 +1,24 @@
---- lib/freebl/Makefile.orig 2018-08-31 12:55:53 UTC
+--- lib/freebl/Makefile.orig 2021-04-15 16:17:44 UTC
+++ lib/freebl/Makefile
-@@ -215,7 +215,7 @@ ifeq ($(CPU_ARCH),x86)
+@@ -263,7 +263,7 @@ else ifeq ($(CPU_ARCH),x86)
endif
endif # Darwin
-ifeq ($(OS_TARGET),Linux)
+ifeq (,$(filter-out Linux FreeBSD, $(OS_TARGET)))
ifeq ($(CPU_ARCH),x86_64)
- ASFILES = arcfour-amd64-gas.s mpi_amd64_gas.s
- ASFLAGS += -fPIC -Wa,--noexecstack
+ # Lower case s on mpi_amd64_common due to make implicit rules.
+ ASFILES = arcfour-amd64-gas.s mpi_amd64_common.s
+@@ -298,10 +298,10 @@ ifdef USE_64
+ PPC_ABI := $(shell $(CC) -dM -E - < /dev/null | awk '$$2 == "_CALL_ELF" {print $$3}')
+ ifeq ($(PPC_ABI),2)
+ ASFILES += sha512-p8.s
+- ifeq ($(OS_TEST),ppc64le)
++ ifeq ($(OS_TEST),powerpc64le)
+ EXTRA_SRCS += chacha20poly1305-ppc.c
+ ASFILES += chacha20-ppc64le.s
+- endif # ppc64le
++ endif # powerpc64le
+ endif
+ endif # USE_64
+ endif # ppc