aboutsummaryrefslogtreecommitdiff
path: root/lang/python39/files
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python39/files')
-rw-r--r--lang/python39/files/patch-Modules___decimal___decimal.c20
-rw-r--r--lang/python39/files/patch-setup.py11
2 files changed, 31 insertions, 0 deletions
diff --git a/lang/python39/files/patch-Modules___decimal___decimal.c b/lang/python39/files/patch-Modules___decimal___decimal.c
new file mode 100644
index 000000000000..12715927ce50
--- /dev/null
+++ b/lang/python39/files/patch-Modules___decimal___decimal.c
@@ -0,0 +1,20 @@
+--- Modules/_decimal/_decimal.c.orig 2020-12-07 14:02:38 UTC
++++ Modules/_decimal/_decimal.c
+@@ -3280,7 +3280,7 @@ dec_format(PyObject *dec, PyObject *args)
+ }
+ else {
+ size_t n = strlen(spec.dot);
+- if (n > 1 || (n == 1 && !isascii((uchar)spec.dot[0]))) {
++ if (n > 1 || (n == 1 && !isascii((unsigned char)spec.dot[0]))) {
+ /* fix locale dependent non-ascii characters */
+ dot = dotsep_as_utf8(spec.dot);
+ if (dot == NULL) {
+@@ -3289,7 +3289,7 @@ dec_format(PyObject *dec, PyObject *args)
+ spec.dot = PyBytes_AS_STRING(dot);
+ }
+ n = strlen(spec.sep);
+- if (n > 1 || (n == 1 && !isascii((uchar)spec.sep[0]))) {
++ if (n > 1 || (n == 1 && !isascii((unsigned char)spec.sep[0]))) {
+ /* fix locale dependent non-ascii characters */
+ sep = dotsep_as_utf8(spec.sep);
+ if (sep == NULL) {
diff --git a/lang/python39/files/patch-setup.py b/lang/python39/files/patch-setup.py
new file mode 100644
index 000000000000..1c943df2af34
--- /dev/null
+++ b/lang/python39/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2021-02-17 17:43:29 UTC
++++ setup.py
+@@ -2196,7 +2196,7 @@ class PyBuildExt(build_ext):
+ undef_macros = []
+ if '--with-system-libmpdec' in sysconfig.get_config_var("CONFIG_ARGS"):
+ include_dirs = []
+- libraries = [':libmpdec.so.2']
++ libraries = ['mpdec']
+ sources = ['_decimal/_decimal.c']
+ depends = ['_decimal/docstrings.h']
+ else: