aboutsummaryrefslogtreecommitdiff
path: root/lang/rust-bootstrap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/rust-bootstrap/Makefile')
-rw-r--r--lang/rust-bootstrap/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/lang/rust-bootstrap/Makefile b/lang/rust-bootstrap/Makefile
index 883cc5e2144c..4fe3721243c1 100644
--- a/lang/rust-bootstrap/Makefile
+++ b/lang/rust-bootstrap/Makefile
@@ -29,7 +29,6 @@ ONLY_FOR_ARCHS_REASON= untested on other archs
BUILD_DEPENDS= cmake:devel/cmake \
gmake:devel/gmake \
- ninja:devel/ninja \
rust>=${PORTVERSION}:lang/rust
FLAVORS= aarch64 amd64 armv6 armv7 i386 powerpc64_elfv1 powerpc64_elfv2 powerpc64le
@@ -46,7 +45,7 @@ powerpc64_elfv1_BUILD_DEPENDS= powerpc64-gcc9>0:devel/freebsd-gcc9@powerpc64
powerpc64_elfv2_PKGNAMEPREFIX= powerpc64-elfv2-
powerpc64le_PKGNAMEPREFIX= powerpc64le-
-USES= perl5 python:3.6+,build tar:xz
+USES= ninja:build perl5 python:3.6+,build tar:xz
.if ${FLAVOR} == powerpc64_elfv1
USE_GCC= 9:build
.endif