aboutsummaryrefslogtreecommitdiff
path: root/multimedia/librist/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/librist/Makefile')
-rw-r--r--multimedia/librist/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/multimedia/librist/Makefile b/multimedia/librist/Makefile
index 3daf56b9f6e3..2f1061143abe 100644
--- a/multimedia/librist/Makefile
+++ b/multimedia/librist/Makefile
@@ -1,5 +1,5 @@
PORTNAME= librist
-DISTVERSION= 0.2.0-RC5.20210325
+DISTVERSION= 0.2.0-RC6
CATEGORIES= multimedia
MAINTAINER= yuri@FreeBSD.org
@@ -8,7 +8,8 @@ COMMENT= Library for Reliable Internet Stream Transport (RIST) protocol
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libcjson.so:devel/libcjson
+LIB_DEPENDS= libcjson.so:devel/libcjson \
+ liblz4.so:archivers/liblz4 # binary doesn't depend on liblz4.so for unknown reason, notified the dev via e-mail on 2021-04-08
USES= localbase meson pkgconfig
USE_GITLAB= yes
@@ -16,8 +17,16 @@ USE_LDCONFIG= yes
GL_SITE= https://code.videolan.org
GL_ACCOUNT= rist
-GL_COMMIT= 24ae978bcacf6a998aa3f2b605690f7d774f9c83
+GL_COMMIT= 9604b7530606b26a40fd95092a2f59d3ee6907d9
-MESON_ARGS= -Duse_mbedtls=false # mbedcrypto needs to be ported
+MESON_ARGS= -Dtest=false
+MESON_ARGS+= -Duse_mbedtls=false # mbedcrypto needs to be ported
+
+do-test:
+ @cd ${WRKSRC} && \
+ ${RM} -r _build && \
+ ${SETENV} ${CONFIGURE_ENV} ${CONFIGURE_CMD} ${CONFIGURE_ARGS} -Dtest=true -Duse_mbedtls=false && \
+ cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} test
.include <bsd.port.mk>