aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2022-06-08 13:59:06 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2022-06-08 14:06:25 +0000
commit00f1472c6af6516e19438c32226a49525860bda2 (patch)
tree170c8802f1802d096be61582a4c0507469f94cc3
parentacd236ae99f87727d9c8b82da357f05ac12556b6 (diff)
downloadports-00f1472c6af6516e19438c32226a49525860bda2.tar.gz
ports-00f1472c6af6516e19438c32226a49525860bda2.zip
pidgin: drop gconf references entirely
Given how the port evolved USE_GNOME=gconf2 was never set anyway, just remove it entirely, and add the configure argument to ensure it will never come back even by accident
-rw-r--r--net-im/finch/Makefile1
-rw-r--r--net-im/libpurple/Makefile10
-rw-r--r--net-im/pidgin/Makefile1
3 files changed, 4 insertions, 8 deletions
diff --git a/net-im/finch/Makefile b/net-im/finch/Makefile
index 02441c64bca1..35307f456a27 100644
--- a/net-im/finch/Makefile
+++ b/net-im/finch/Makefile
@@ -23,6 +23,7 @@ CPE_PRODUCT= pidgin
CPPFLAGS+= -DNCURSES_WIDECHAR -D_XOPEN_SOURCE_EXTENDED
USE_LDCONFIG= yes
CONFIGURE_ARGS= --disable-gtkui \
+ --disable-schemas-install \
--disable-nm \
--with-dynamic_prpls=${PRPL_MODULES:S/,$//}
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index fb7118836367..126894c0b5f0 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -21,7 +21,8 @@ CONFIGURE_ARGS?=--disable-gtkui \
--with-dynamic-prpls=${PRPL_MODULES:S/,$//} \
--enable-static \
--disable-nm \
- --with-system-ssl-certs=/usr/share/certs/trusted
+ --with-system-ssl-certs=/usr/share/certs/trusted \
+ --disable-schemas-install
INSTALL_TARGET= install-strip
.if !defined(PIDGIN_SLAVE)
@@ -114,11 +115,6 @@ PLIST_SUB+= PERL:="@comment not installed: " \
PERLMAN:="@comment not installed: "
.endif
-.if defined(WITH_GTKUI) && !defined(PIDGIN_SLAVE)
-USE_GNOME+= gconf2
-GCONF_SCHEMAS= purple.schemas
-.endif
-
.if defined(WITH_GTKUI)
USE_GNOME+= evolutiondataserver3
PLIST_SUB+= EVO=""
@@ -296,8 +292,6 @@ post-patch:
.if defined(PIDGIN_SLAVE)
@${FIND} ${BUILD_WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|$$(top_builddir)/libpurple/libpurple.la|-lpurple|'
- @${REINPLACE_CMD} -e 's|gconftool-2|gconftool-disabled|g' \
- ${WRKSRC}/configure
.endif
.if !defined(PIDGIN_SLAVE) && ${PORT_OPTIONS:MPERL}
diff --git a/net-im/pidgin/Makefile b/net-im/pidgin/Makefile
index 82f6f09f5bc1..b565a5a00b52 100644
--- a/net-im/pidgin/Makefile
+++ b/net-im/pidgin/Makefile
@@ -25,6 +25,7 @@ USE_XORG= xscrnsaver sm
CONFIGURE_ARGS= --disable-consoleui \
--disable-nm \
--enable-screensaver \
+ --disable-schemas-install
--with-dynamic_prpls=${PRPL_MODULES:S/,$//}
post-install-PERL-on: