aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDries Michiels <driesm.michiels@gmail.com>2021-10-31 04:21:37 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2021-10-31 04:35:13 +0000
commit01223a9c0d50f4a263beacb400770ae1085d111d (patch)
treefb6bfd26b4a7b8c38da57decd0ae9dfbbb89fa51
parent1cd8dc16bf18b606188017b6e7debfde93293440 (diff)
downloadports-01223a9c0d50f4a263beacb400770ae1085d111d.tar.gz
ports-01223a9c0d50f4a263beacb400770ae1085d111d.zip
net/dhcpcd: Fix build when TOP environment viriable is set
PR: 253270 Reported by: Volodymyr Kostyrko (cherry picked from commit 9e078ab7b7515a325c0ce7b6089e638e8ce0e63c)
-rw-r--r--net/dhcpcd/Makefile1
-rw-r--r--net/dhcpcd/files/patch-hooks_Makefile8
-rw-r--r--net/dhcpcd/files/patch-src_Makefile11
-rw-r--r--net/dhcpcd/files/patch-src_dev_Makefile8
-rw-r--r--net/dhcpcd/files/patch-tests_crypt_Makefile8
-rw-r--r--net/dhcpcd/files/patch-tests_eloop-bench_Makefile8
6 files changed, 44 insertions, 0 deletions
diff --git a/net/dhcpcd/Makefile b/net/dhcpcd/Makefile
index 45222564301b..744e540e21ca 100644
--- a/net/dhcpcd/Makefile
+++ b/net/dhcpcd/Makefile
@@ -2,6 +2,7 @@
PORTNAME= dhcpcd
PORTVERSION= 9.4.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://roy.marples.name/downloads/dhcpcd/ \
https://cflags.cc/roy/dhcpcd/
diff --git a/net/dhcpcd/files/patch-hooks_Makefile b/net/dhcpcd/files/patch-hooks_Makefile
new file mode 100644
index 000000000000..7416f5dbe6ca
--- /dev/null
+++ b/net/dhcpcd/files/patch-hooks_Makefile
@@ -0,0 +1,8 @@
+--- hooks/Makefile.orig 2020-12-28 12:59:20 UTC
++++ hooks/Makefile
+@@ -1,4 +1,4 @@
+-TOP?= ../
++TOP= ../
+ include ${TOP}/iconfig.mk
+
+ PROG= dhcpcd-run-hooks
diff --git a/net/dhcpcd/files/patch-src_Makefile b/net/dhcpcd/files/patch-src_Makefile
new file mode 100644
index 000000000000..35217a33629b
--- /dev/null
+++ b/net/dhcpcd/files/patch-src_Makefile
@@ -0,0 +1,11 @@
+--- src/Makefile.orig 2021-09-10 17:26:01 UTC
++++ src/Makefile
+@@ -8,7 +8,7 @@ SRCS+= dhcp-common.c script.c
+ CFLAGS?= -O2
+ SUBDIRS+= ${MKDIRS}
+
+-TOP?= ..
++TOP= ..
+ include ${TOP}/iconfig.mk
+
+ CSTD?= c99
diff --git a/net/dhcpcd/files/patch-src_dev_Makefile b/net/dhcpcd/files/patch-src_dev_Makefile
new file mode 100644
index 000000000000..a171fdc5358c
--- /dev/null
+++ b/net/dhcpcd/files/patch-src_dev_Makefile
@@ -0,0 +1,8 @@
+--- src/dev/Makefile.orig 2020-12-28 12:59:20 UTC
++++ src/dev/Makefile
+@@ -1,4 +1,4 @@
+-TOP?= ../../
++TOP= ../../
+ include ${TOP}/Makefile.inc
+ include ${TOP}/config.mk
+
diff --git a/net/dhcpcd/files/patch-tests_crypt_Makefile b/net/dhcpcd/files/patch-tests_crypt_Makefile
new file mode 100644
index 000000000000..1f19ccea56b9
--- /dev/null
+++ b/net/dhcpcd/files/patch-tests_crypt_Makefile
@@ -0,0 +1,8 @@
+--- tests/crypt/Makefile.orig 2020-12-28 12:59:20 UTC
++++ tests/crypt/Makefile
+@@ -1,4 +1,4 @@
+-TOP?= ../..
++TOP= ../..
+ include ${TOP}/iconfig.mk
+
+ PROG= run-test
diff --git a/net/dhcpcd/files/patch-tests_eloop-bench_Makefile b/net/dhcpcd/files/patch-tests_eloop-bench_Makefile
new file mode 100644
index 000000000000..7e5cb9ac750a
--- /dev/null
+++ b/net/dhcpcd/files/patch-tests_eloop-bench_Makefile
@@ -0,0 +1,8 @@
+--- tests/eloop-bench/Makefile.orig 2020-12-28 12:59:20 UTC
++++ tests/eloop-bench/Makefile
+@@ -1,4 +1,4 @@
+-TOP?= ../..
++TOP= ../..
+ include ${TOP}/iconfig.mk
+
+ PROG= eloop-bench