aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2023-04-05 18:52:32 +0000
committerGleb Popov <arrowd@FreeBSD.org>2023-04-07 06:52:53 +0000
commit018274cbc53802b98950eb504337f1987fba5905 (patch)
tree1ceb93391e33be42e997c84875b00cc227dd73de
parentcf4dad03cd675d9a3f745091cb46f62d2f1159c6 (diff)
downloadports-018274cbc53802b98950eb504337f1987fba5905.tar.gz
ports-018274cbc53802b98950eb504337f1987fba5905.zip
lang/ghc: Replace GMP_CONFIGURE_WITH with GMP_CONFIGURE_ON.
-rw-r--r--lang/ghc/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 69e1852f5a53..d7db35d0ebe2 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -54,8 +54,11 @@ DYNAMIC_LIB_DEPENDS= libffi.so:devel/libffi
DYNAMIC_VARS= enable_dynamic=YES
DYNAMIC_VARS_OFF= enable_dynamic=NO
-GMP_CONFIGURE_WITH= gmp-includes=${LOCALBASE}/include \
- gmp-libraries=${LOCALBASE}/lib
+# do not replace this with GMP_CONFIGURE_WITH
+# it adds "--without-gmp-*" when the option is OFF, which results in "no" value
+# to be used as directory name
+GMP_CONFIGURE_ON= --with-gmp-includes=${LOCALBASE}/include \
+ --with-gmp-libraries=${LOCALBASE}/lib
GMP_LIB_DEPENDS= libgmp.so:math/gmp
PROFILE_VARS= enable_profile=YES