aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-10-18 07:37:18 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-10-18 07:40:15 +0000
commit01bf2c9e3c7a5c7711a3e4aa0af08ba4a2b97c7b (patch)
treef23f0114d9e6711f4e8a800e8cccc36b2c428f84
parent4b655e4ef790f556473c8ad8b560154e41b06cd3 (diff)
downloadports-01bf2c9e3c7a5c7711a3e4aa0af08ba4a2b97c7b.tar.gz
ports-01bf2c9e3c7a5c7711a3e4aa0af08ba4a2b97c7b.zip
devel/docopt.cpp: Update 0.6.3 -> 0.6.3-5
-rw-r--r--devel/docopt.cpp/Makefile18
-rw-r--r--devel/docopt.cpp/distinfo6
-rw-r--r--devel/docopt.cpp/files/patch-CMakeLists.txt38
3 files changed, 13 insertions, 49 deletions
diff --git a/devel/docopt.cpp/Makefile b/devel/docopt.cpp/Makefile
index 7a0108cc31ef..83d8073018f1 100644
--- a/devel/docopt.cpp/Makefile
+++ b/devel/docopt.cpp/Makefile
@@ -1,6 +1,7 @@
PORTNAME= docopt.cpp
DISTVERSIONPREFIX= v
-DISTVERSION= 0.6.3
+DISTVERSION= 0.6.3-5
+DISTVERSIONSUFFIX= -g400e6dd
CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org
@@ -10,17 +11,18 @@ WWW= https://github.com/docopt/docopt.cpp
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE-MIT
-TEST_DEPENDS= python${PYTHON_DEFAULT}:lang/python${PYTHON_DEFAULT:S/.//}
+USES= cmake:testing compiler:c++11-lang python:test
+USE_LDCONFIG= yes
-USES= cmake compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= docopt
-USE_LDCONFIG= yes
-do-test:
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_TESTING_ON= WITH_TESTS
+CMAKE_TESTING_TARGET= ${ALL_TARGET}
+
+post-test:
@cd ${BUILD_WRKSRC} && \
- ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DWITH_TESTS=ON ${CMAKE_SOURCE_PATH} && \
- ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
- python${PYTHON_DEFAULT} run_tests
+ ${PYTHON_CMD} run_tests
.include <bsd.port.mk>
diff --git a/devel/docopt.cpp/distinfo b/devel/docopt.cpp/distinfo
index 707225565fe5..cd45001194c2 100644
--- a/devel/docopt.cpp/distinfo
+++ b/devel/docopt.cpp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1592234659
-SHA256 (docopt-docopt.cpp-v0.6.3_GH0.tar.gz) = 28af5a0c482c6d508d22b14d588a3b0bd9ff97135f99c2814a5aa3cbff1d6632
-SIZE (docopt-docopt.cpp-v0.6.3_GH0.tar.gz) = 27598
+TIMESTAMP = 1666077016
+SHA256 (docopt-docopt.cpp-v0.6.3-5-g400e6dd_GH0.tar.gz) = 91cf2a9a7d5cf3303f09a64bd1b8bd0b5e7732ae4cb8f89c8f82d55aa94cdf13
+SIZE (docopt-docopt.cpp-v0.6.3-5-g400e6dd_GH0.tar.gz) = 27296
diff --git a/devel/docopt.cpp/files/patch-CMakeLists.txt b/devel/docopt.cpp/files/patch-CMakeLists.txt
deleted file mode 100644
index edc9019dcba4..000000000000
--- a/devel/docopt.cpp/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,38 +0,0 @@
---- CMakeLists.txt.orig 2020-05-11 17:23:10 UTC
-+++ CMakeLists.txt
-@@ -42,7 +42,7 @@ if(MSVC OR XCODE)
- # Xcode does not support libraries with only object files as sources.
- # See https://cmake.org/cmake/help/v3.0/command/add_library.html?highlight=add_library
- add_library(docopt SHARED ${docopt_SOURCES} ${docopt_HEADERS})
-- add_library(docopt_s STATIC ${docopt_SOURCES} ${docopt_HEADERS})
-+ #add_library(docopt_s STATIC ${docopt_SOURCES} ${docopt_HEADERS})
- else()
- # If not using MSVC or Xcode, we will create an intermediate object target
- # to avoid compiling the source code twice.
-@@ -71,7 +71,7 @@ endif()
-
- if(NOT MSVC)
- set_target_properties(docopt PROPERTIES OUTPUT_NAME docopt)
-- set_target_properties(docopt_s PROPERTIES OUTPUT_NAME docopt)
-+ #set_target_properties(docopt_s PROPERTIES OUTPUT_NAME docopt)
- endif()
-
- if(USE_BOOST_REGEX)
-@@ -83,7 +83,7 @@ if(USE_BOOST_REGEX)
- include_directories(${Boost_INCLUDE_DIRS})
- target_link_libraries(docopt ${Boost_LIBRARIES})
- if(WITH_STATIC)
-- target_link_libraries(docopt_s ${Boost_LIBRARIES})
-+ #target_link_libraries(docopt_s ${Boost_LIBRARIES})
- endif()
- endif()
-
-@@ -120,7 +120,7 @@ set(export_name "docopt-targets")
- install(TARGETS docopt EXPORT ${export_name} DESTINATION ${CMAKE_INSTALL_LIBDIR})
-
- # Development package
--install(TARGETS docopt_s EXPORT ${export_name} DESTINATION ${CMAKE_INSTALL_LIBDIR})
-+#install(TARGETS docopt_s EXPORT ${export_name} DESTINATION ${CMAKE_INSTALL_LIBDIR})
- install(FILES ${docopt_HEADERS} DESTINATION include/docopt)
-
- # CMake Package