aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-07-30 05:59:02 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-07-30 05:59:02 +0000
commit01c9d84f2108c5e70eb6c806b2488cb9dc896479 (patch)
tree3a53e56641a34c16938c98e5dedf6831063f7155
parent15328d56f00997b5fa78148a270034990250146a (diff)
downloadports-01c9d84f2108c5e70eb6c806b2488cb9dc896479.tar.gz
ports-01c9d84f2108c5e70eb6c806b2488cb9dc896479.zip
www/rubygem-sinatra-contrib: Fix gemspec for rubygem-mustermann 2.0.1 update
-rw-r--r--www/rubygem-sinatra-contrib/Makefile3
-rw-r--r--www/rubygem-sinatra-contrib/files/patch-gemspec11
2 files changed, 13 insertions, 1 deletions
diff --git a/www/rubygem-sinatra-contrib/Makefile b/www/rubygem-sinatra-contrib/Makefile
index 943da13598de..0f04d8ad6fa8 100644
--- a/www/rubygem-sinatra-contrib/Makefile
+++ b/www/rubygem-sinatra-contrib/Makefile
@@ -1,5 +1,6 @@
PORTNAME= sinatra-contrib
PORTVERSION= 2.2.1
+PORTREVISION= 1
CATEGORIES= www rubygems
MASTER_SITES= RG
@@ -10,7 +11,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= rubygem-multi_json>=0:devel/rubygem-multi_json \
- rubygem-mustermann>=1.0<2:devel/rubygem-mustermann \
+ rubygem-mustermann>=2.0<3:devel/rubygem-mustermann \
rubygem-rack-protection>=${PORTVERSION}:www/rubygem-rack-protection \
rubygem-sinatra>=${PORTVERSION}:www/rubygem-sinatra \
rubygem-tilt>=2.0<3:devel/rubygem-tilt
diff --git a/www/rubygem-sinatra-contrib/files/patch-gemspec b/www/rubygem-sinatra-contrib/files/patch-gemspec
new file mode 100644
index 000000000000..7c16924b19df
--- /dev/null
+++ b/www/rubygem-sinatra-contrib/files/patch-gemspec
@@ -0,0 +1,11 @@
+--- sinatra-contrib.gemspec.orig 2022-07-22 17:38:56 UTC
++++ sinatra-contrib.gemspec
+@@ -25,7 +25,7 @@ Gem::Specification.new do |s|
+
+ if s.respond_to? :add_runtime_dependency then
+ s.add_runtime_dependency(%q<sinatra>.freeze, ["= 2.2.1"])
+- s.add_runtime_dependency(%q<mustermann>.freeze, ["~> 1.0"])
++ s.add_runtime_dependency(%q<mustermann>.freeze, ["~> 2.0"])
+ s.add_runtime_dependency(%q<tilt>.freeze, ["~> 2.0"])
+ s.add_runtime_dependency(%q<rack-protection>.freeze, ["= 2.2.1"])
+ s.add_runtime_dependency(%q<multi_json>.freeze, [">= 0"])