aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesús Daniel Colmenares Oviedo <DtxdF@disroot.org>2022-09-23 16:41:06 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2022-10-25 18:41:38 +0000
commit01e61056c897d9d905c7510a689e45613d12dc6b (patch)
tree33c1557f1d89e3f6fc9ece690f4980616041a774
parente62e9ecee2e57c64391e9b90c33bd7fee8ccd72a (diff)
downloadports-01e61056c897d9d905c7510a689e45613d12dc6b.tar.gz
ports-01e61056c897d9d905c7510a689e45613d12dc6b.zip
Add textproc/py-extract-msg: Extracts emails and attachments saved in MS Outlook's .msg files
msg-extract extracts emails and attachments saved in Microsoft Outlook's .msg files. It automates the extraction of key email data (from, to, cc, date, subject, body) and the email's attachments. WWW: https://github.com/TeamMsgExtractor/msg-extractor PR: 265765
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-extract-msg/Makefile28
-rw-r--r--textproc/py-extract-msg/distinfo3
-rw-r--r--textproc/py-extract-msg/pkg-descr3
4 files changed, 35 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 9d4557912f45..5b5097135fcb 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1327,6 +1327,7 @@
SUBDIR += py-enchant
SUBDIR += py-enrich
SUBDIR += py-et_xmlfile
+ SUBDIR += py-extract-msg
SUBDIR += py-fastavro
SUBDIR += py-feedparser
SUBDIR += py-fingerprints
diff --git a/textproc/py-extract-msg/Makefile b/textproc/py-extract-msg/Makefile
new file mode 100644
index 000000000000..8b0c4160a51b
--- /dev/null
+++ b/textproc/py-extract-msg/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= extract-msg
+PORTVERSION= 0.36.3
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= extract_msg-${PORTVERSION}
+
+MAINTAINER= DtxdF@disroot.org
+COMMENT= Extracts emails and attachments saved in MS Outlook's .msg files
+WWW= https://github.com/TeamMsgExtractor/msg-extractor
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.11.1:www/py-beautifulsoup@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}chardet>=4.0.0:textproc/py-chardet@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}compressed-rtf>=1.0.6:archivers/py-compressed-rtf@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ebcdic>=1.1.1:textproc/py-ebcdic@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}imapclient>=2.1.0:mail/py-imapclient@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}olefile>=0.46:devel/py-olefile@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz-deprecation-shim>0:devel/py-pytz-deprecation-shim@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}RTFDE>=0.0.2:textproc/py-RTFDE@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tzlocal>=4.2:devel/py-tzlocal@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/textproc/py-extract-msg/distinfo b/textproc/py-extract-msg/distinfo
new file mode 100644
index 000000000000..2bfb37556748
--- /dev/null
+++ b/textproc/py-extract-msg/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1662216238
+SHA256 (extract_msg-0.36.3.tar.gz) = eb5726ecf9f482aec2323dd06250d76dc514c8dc6f87804fb835bd0106e221c8
+SIZE (extract_msg-0.36.3.tar.gz) = 158680
diff --git a/textproc/py-extract-msg/pkg-descr b/textproc/py-extract-msg/pkg-descr
new file mode 100644
index 000000000000..8faa87ebb2e1
--- /dev/null
+++ b/textproc/py-extract-msg/pkg-descr
@@ -0,0 +1,3 @@
+msg-extract extracts emails and attachments saved in Microsoft
+Outlook's .msg files. It automates the extraction of key email data
+(from, to, cc, date, subject, body) and the email's attachments.