aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-01-05 04:24:37 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-01-05 15:07:54 +0000
commit024e2eaf982905be2a8b80e7b54311154647af94 (patch)
treefc8a8edfefdd690dc64ba2ae38ac72e02a50a0ef
parent9218e76367febc39046abf36b61a532437b0ebc6 (diff)
downloadports-024e2eaf982905be2a8b80e7b54311154647af94.tar.gz
ports-024e2eaf982905be2a8b80e7b54311154647af94.zip
devel/hyprlang: unbreak build with libc++ 16
src/config.cpp:276:42: error: no member named 'format' in namespace 'std' result.setError(std::format("special category's first value must be the key. Key for <{}> is <{}>", PCAT->name, PCAT->key)); ~~~~~^ src/config.cpp:287:34: error: no member named 'format' in namespace 'std' result.setError(std::format("config option <{}> does not exist.", valueName)); ~~~~~^ src/config.cpp:297:38: error: no member named 'format' in namespace 'std' result.setError(std::format("failed parsing an int: {}", e.what())); ~~~~~^ src/config.cpp:306:38: error: no member named 'format' in namespace 'std' result.setError(std::format("failed parsing a float: {}", e.what())); ~~~~~^ src/config.cpp:324:38: error: no member named 'format' in namespace 'std' result.setError(std::format("failed parsing a vec2: {}", e.what())); ~~~~~^ src/config.cpp:533:38: error: no member named 'format' in namespace 'std' impl->parseError += std::format("Config error in file {} at line {}: {}", file, linenum, RET.errorStdString); ~~~~~^ src/config.cpp:546:38: error: no member named 'format' in namespace 'std' impl->parseError += std::format("Config error in file {}: Unclosed category at EOF", file); ~~~~~^ Reported by: pkg-fallout
-rw-r--r--devel/hyprlang/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/devel/hyprlang/Makefile b/devel/hyprlang/Makefile
index ce8b7557ccc5..c67f2d34f8d0 100644
--- a/devel/hyprlang/Makefile
+++ b/devel/hyprlang/Makefile
@@ -23,4 +23,10 @@ PLIST_FILES= include/${PORTNAME}.hpp \
lib/lib${PORTNAME}.so \
share/pkgconfig/${PORTNAME}.pc
+# XXX Drop after FreeBSD 14.0 EOL around 2025-03-01
+.if exists(/usr/include/c++/v1/__format/format_functions.h) && \
+ !exists(/usr/include/c++/v1/__format/write_escaped.h)
+CXXFLAGS+= -fexperimental-library
+.endif
+
.include <bsd.port.mk>