aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-07-03 23:57:33 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-07-04 00:00:33 +0000
commit028028ffbc6d1de41f6a60d385b28f5bda4b0d50 (patch)
tree84c6edd18107013a44dede77effd6da3da4d78ff
parentba84d310347c310c9d31400783b9aa985b3b7185 (diff)
downloadports-028028ffbc6d1de41f6a60d385b28f5bda4b0d50.tar.gz
ports-028028ffbc6d1de41f6a60d385b28f5bda4b0d50.zip
science/dftbplus: unbreak on powerpc* / main
Builds fine.
-rw-r--r--science/dftbplus/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/science/dftbplus/Makefile b/science/dftbplus/Makefile
index 70e00e072f19..272e2b4c0495 100644
--- a/science/dftbplus/Makefile
+++ b/science/dftbplus/Makefile
@@ -7,9 +7,12 @@ COMMENT= DFTB+: Package for performing fast atomistic simulations
LICENSE= GPLv3 # main code is under LGPL3+, the bundled dftd3-lib is under GPLv1+, this makes the result GPLv3 (based on https://www.gnu.org/licenses/gpl-faq.html#AllCompatibility)
-.for arch in aarch64 powerpc powerpc64 powerpc64le
-BROKEN_${arch}= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug\#255890
-.endfor
+BROKEN_aarch64= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug\#255890
+BROKEN_FreeBSD_12_powerpc= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug\#255890
+BROKEN_FreeBSD_12_powerpc64= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug\#255890
+BROKEN_FreeBSD_13_powerpc= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug\#255890
+BROKEN_FreeBSD_13_powerpc64= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug\#255890
+BROKEN_FreeBSD_13_powerpc64le= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug\#255890
LIB_DEPENDS= libblas.so:math/blas \
liblapack.so:math/lapack \