aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-30 23:29:48 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-30 23:29:48 +0000
commit03214da397df51e85cf422b5c7dded98efee9444 (patch)
tree07bf64507e6d075e35842794b8f0edadfbe0d785
parent27df4556ee4c609bf952cee4fec87e58c1b200c3 (diff)
downloadports-03214da397df51e85cf422b5c7dded98efee9444.tar.gz
ports-03214da397df51e85cf422b5c7dded98efee9444.zip
archivers/liblz4: Use upstream release tarball
- Update WWW - Use complete arguments/options - Simplify SHEBANG_FILES - Update pkg-descr
-rw-r--r--archivers/liblz4/Makefile26
-rw-r--r--archivers/liblz4/distinfo6
-rw-r--r--archivers/liblz4/pkg-descr19
3 files changed, 31 insertions, 20 deletions
diff --git a/archivers/liblz4/Makefile b/archivers/liblz4/Makefile
index 318fe4f24a08..99ca3824f368 100644
--- a/archivers/liblz4/Makefile
+++ b/archivers/liblz4/Makefile
@@ -1,30 +1,36 @@
PORTNAME= lz4
-DISTVERSIONPREFIX= v
-DISTVERSION= 1.9.4
+PORTVERSION= 1.9.4
PORTEPOCH= 1
CATEGORIES= archivers
+MASTER_SITES= https://github.com/lz4/lz4/releases/download/v${PORTVERSION}/
PKGNAMEPREFIX= lib
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= LZ4 compression library, lossless and very fast
-WWW= https://lz4.github.io/lz4/
+WWW= https://lz4.org/ \
+ https://github.com/lz4/lz4
LICENSE= BSD2CLAUSE GPLv2
LICENSE_COMB= multi
USES= cpe meson pkgconfig python:build shebangfix
-USE_GITHUB= yes
+
+MESON_ARGS= --default-library=both \
+ -Dcontrib=false \
+ -Dexamples=false \
+ -Dmemory-usage=0 \
+ -Dprograms=true \
+ -Dunstable=false
USE_LDCONFIG= yes
-CPE_VENDOR= lz4_project
+WRKSRC_SUBDIR= contrib/meson
-SHEBANG_FILES= meson/*.py \
- ${WRKDIR}/${PORTNAME}-${DISTVERSION}/tests/*.py
+PLIST_SUB= PORTVERSION=${PORTVERSION}
-MESON_ARGS= -Ddefault_library=both -Dprograms=true
+CPE_VENDOR= lz4_project
-WRKSRC_SUBDIR= contrib/meson
+PORTSCOUT= limit:^[0-9]*\.
-PLIST_SUB= PORTVERSION=${PORTVERSION}
+SHEBANG_FILES= ../../tests/*.py meson/*.py
OPTIONS_DEFINE= TEST
diff --git a/archivers/liblz4/distinfo b/archivers/liblz4/distinfo
index 059e61f0076b..c9ce22ab0a3a 100644
--- a/archivers/liblz4/distinfo
+++ b/archivers/liblz4/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1661592056
-SHA256 (lz4-lz4-v1.9.4_GH0.tar.gz) = 0b0e3aa07c8c063ddf40b082bdf7e37a1562bda40a0ff5272957f3e987e0e54b
-SIZE (lz4-lz4-v1.9.4_GH0.tar.gz) = 354063
+TIMESTAMP = 1696103937
+SHA256 (lz4-1.9.4.tar.gz) = 0b0e3aa07c8c063ddf40b082bdf7e37a1562bda40a0ff5272957f3e987e0e54b
+SIZE (lz4-1.9.4.tar.gz) = 354063
diff --git a/archivers/liblz4/pkg-descr b/archivers/liblz4/pkg-descr
index 76872afa1426..45cd8733f136 100644
--- a/archivers/liblz4/pkg-descr
+++ b/archivers/liblz4/pkg-descr
@@ -1,9 +1,14 @@
-LZ4 is a very fast lossless compression algorithm, providing compression speed
-at 400 MB/s per core, scalable with multi-cores CPU. It also features an
-extremely fast decoder, with speed in multiple GB/s per core, typically
-reaching RAM speed limits on multi-core systems.
+LZ4 is lossless compression algorithm, providing compression speed > 500 MB/s
+per core, scalable with multi-cores CPU. It features an extremely fast decoder,
+with speed in multiple GB/s per core, typically reaching RAM speed limits on
+multi-core systems.
-A high compression derivative, called LZ4_HC, is also provided. It trades CPU
-time for compression ratio.
+Speed can be tuned dynamically, selecting an "acceleration" factor which trades
+compression ratio for faster speed. On the other end, a high compression
+derivative, LZ4_HC, is also provided, trading CPU time for improved compression
+ratio. All versions feature the same decompression speed.
-The libraries are BSD licensed, and the binaries are GPLv2.
+LZ4 is also compatible with dictionary compression, both at API and CLI levels.
+It can ingest any input file as dictionary, though only the final 64KB are used.
+This capability can be combined with the Zstandard Dictionary Builder, in order
+to drastically improve compression performance on small files.