aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-02-13 07:45:19 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-02-13 09:10:51 +0000
commit0339e00c364b887ae2bfc544d12049996289e9f7 (patch)
tree50785e9abadade8ca552a722221fac7b9cf76994
parent65985e68b04ebc41504bf5a014b0ebdd2868fc54 (diff)
downloadports-0339e00c364b887ae2bfc544d12049996289e9f7.tar.gz
ports-0339e00c364b887ae2bfc544d12049996289e9f7.zip
finance/py-technical: New port: Various indicators developed or collected for the Freqtrade
-rw-r--r--finance/Makefile1
-rw-r--r--finance/py-technical/Makefile32
-rw-r--r--finance/py-technical/distinfo3
-rw-r--r--finance/py-technical/pkg-descr2
4 files changed, 38 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 84f66ccadd4b..c221ee7a3b7f 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -125,6 +125,7 @@
SUBDIR += py-quantecon
SUBDIR += py-stripe
SUBDIR += py-ta-lib
+ SUBDIR += py-technical
SUBDIR += py-vatnumber
SUBDIR += py-yfinance
SUBDIR += py-ystockquote
diff --git a/finance/py-technical/Makefile b/finance/py-technical/Makefile
new file mode 100644
index 000000000000..e3af83554f2f
--- /dev/null
+++ b/finance/py-technical/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= technical
+DISTVERSION= 1.4.0
+CATEGORIES= finance python
+#MASTER_SITES= PYPI # no test data
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Various indicators developed or collected for the Freqtrade
+WWW= https://github.com/freqtrade/technical
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pandas>=1.5.3:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ta-lib>=0.4.25:finance/py-ta-lib@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=46.4.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR} \
+ ${PY_DEPENDS}
+RUN_DEPENDS= ${PY_DEPENDS}
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-mock>0:devel/py-pytest-mock@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 autoplist pytest
+
+USE_GITHUB= yes
+GH_ACCOUNT= freqtrade
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/finance/py-technical/distinfo b/finance/py-technical/distinfo
new file mode 100644
index 000000000000..b778f0112e8b
--- /dev/null
+++ b/finance/py-technical/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1676271748
+SHA256 (freqtrade-technical-1.4.0_GH0.tar.gz) = 15801f70aa65dad53c2648d5ca74c59f8db220556a4c908506d81a16cf991413
+SIZE (freqtrade-technical-1.4.0_GH0.tar.gz) = 293628
diff --git a/finance/py-technical/pkg-descr b/finance/py-technical/pkg-descr
new file mode 100644
index 000000000000..c0695912a678
--- /dev/null
+++ b/finance/py-technical/pkg-descr
@@ -0,0 +1,2 @@
+Technical is a collection of technical indicators collected or developed for
+Freqtrade as well as utilities such as timeframe resampling.