aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHung-Yi Chen <gaod@hychen.org>2024-01-14 08:04:41 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-01-14 20:28:30 +0000
commit03dfdf49875c7634f458e4eddad9db2a850d6e41 (patch)
tree8c0a86784f22c1aa8515ed567d80e4d54b43654b
parentd7a3206d8a0b04dd447d6da6a73a4c20067b4afc (diff)
downloadports-03dfdf49875c7634f458e4eddad9db2a850d6e41.tar.gz
ports-03dfdf49875c7634f458e4eddad9db2a850d6e41.zip
sysutils/apachetop: Update to 0.23.2
Changelog: https://github.com/tessus/apachetop/blob/master/ChangeLog PR: 276300 Reviewed by: Lukasz Wasikowski <lukasz@wasikowski.net> (maintainer)
-rw-r--r--sysutils/apachetop/Makefile9
-rw-r--r--sysutils/apachetop/distinfo6
-rw-r--r--sysutils/apachetop/files/patch-src_inlines.cc37
-rw-r--r--sysutils/apachetop/files/patch-src_ohtbl.cc38
4 files changed, 8 insertions, 82 deletions
diff --git a/sysutils/apachetop/Makefile b/sysutils/apachetop/Makefile
index cac6e66c9ad7..87317aa98576 100644
--- a/sysutils/apachetop/Makefile
+++ b/sysutils/apachetop/Makefile
@@ -1,5 +1,5 @@
PORTNAME= apachetop
-DISTVERSION= 0.19.7
+DISTVERSION= 0.23.2
CATEGORIES= sysutils
MASTER_SITES= https://github.com/tessus/${PORTNAME}/releases/download/${DISTVERSION}/
@@ -18,7 +18,7 @@ CONFIGURE_ENV+= NCURSES_CFLAGS="-I${NCURSESINC}" NCURSES_LIBS="-lncursesw"
PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
-OPTIONS_DEFINE= ADNS FAM PCRE
+OPTIONS_DEFINE= ADNS FAM PCRE2
ADNS_DESC= Asynchronous-capable DNS support
ADNS_LIB_DEPENDS= libadns.so:dns/adns
@@ -27,7 +27,8 @@ ADNS_CONFIGURE_WITH= adns=${LOCALBASE}
FAM_LIB_DEPENDS= libfam.so:devel/fam
FAM_CONFIGURE_WITH= fam=${LOCALBASE}
-PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
-PCRE_CONFIGURE_WITH= pcre=${LOCALBASE}
+PCRE2_DESC= Use Perl Compatible Regular Expressions (v2)
+PCRE2_LIB_DEPENDS= libpcre2-8.so:devel/pcre2
+PCRE2_CONFIGURE_WITH= pcre2=${LOCALBASE}
.include <bsd.port.mk>
diff --git a/sysutils/apachetop/distinfo b/sysutils/apachetop/distinfo
index 00b68e76ab2c..65ba839f3d59 100644
--- a/sysutils/apachetop/distinfo
+++ b/sysutils/apachetop/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1660844272
-SHA256 (apachetop-0.19.7.tar.gz) = 7f0ad1cd11cd1f86052bbfd63f27ecb6cb74012a17321354af70abf05998c4eb
-SIZE (apachetop-0.19.7.tar.gz) = 132665
+TIMESTAMP = 1705166125
+SHA256 (apachetop-0.23.2.tar.gz) = f94a34180808c3edb24c1779f72363246dd4143a89f579ef2ac168a45b04443f
+SIZE (apachetop-0.23.2.tar.gz) = 169381
diff --git a/sysutils/apachetop/files/patch-src_inlines.cc b/sysutils/apachetop/files/patch-src_inlines.cc
deleted file mode 100644
index de6746fd2c0b..000000000000
--- a/sysutils/apachetop/files/patch-src_inlines.cc
+++ /dev/null
@@ -1,37 +0,0 @@
---- src/inlines.cc.orig 2018-08-28 11:21:23 UTC
-+++ src/inlines.cc
-@@ -4,10 +4,10 @@
- #define ONE_EIGHTH 4
- #define HIGH_BITS (~((unsigned int)(~0) >> ONE_EIGHTH))
-
--inline unsigned int StringHash(register const char *str)
-+inline unsigned int StringHash( const char *str)
- {
-- register unsigned int val;
-- register unsigned int i;
-+ unsigned int val;
-+ unsigned int i;
-
- for (val = 0; *str; str++)
- {
-@@ -19,9 +19,9 @@ inline unsigned int StringHash(register const char *st
- return val;
- }
-
--inline unsigned int QuickHash(register const char *str)
-+inline unsigned int QuickHash( const char *str)
- {
-- register unsigned int val, tmp;
-+ unsigned int val, tmp;
-
- for(val = 0 ; *str ; str++)
- {
-@@ -32,7 +32,7 @@ inline unsigned int QuickHash(register const char *str
- return val;
- }
-
--inline unsigned long TTHash(register const char *str)
-+inline unsigned long TTHash( const char *str)
- {
- unsigned long hash = 5381;
- int c;
diff --git a/sysutils/apachetop/files/patch-src_ohtbl.cc b/sysutils/apachetop/files/patch-src_ohtbl.cc
deleted file mode 100644
index da8877a4e9b5..000000000000
--- a/sysutils/apachetop/files/patch-src_ohtbl.cc
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/ohtbl.cc.orig 2018-08-28 11:24:15 UTC
-+++ src/ohtbl.cc
-@@ -13,7 +13,7 @@ static int primes[] = {101, 241, 499, 1009, 2003, 3001
-
- int OAHash::getNextPrime(int size)
- {
-- register int *prime;
-+ int *prime;
- for (prime = &primes[0] ; *prime ; prime++)
- if (*prime > size)
- return *prime;
-@@ -51,7 +51,7 @@ void OAHash::destroy(void)
-
- void *OAHash::insert(char *key, void *data)
- {
-- register unsigned int p, i;
-+ unsigned int p, i;
- void *d;
-
- // Do not exceed the number of positions in the table.
-@@ -81,7 +81,7 @@ void *OAHash::insert(char *key, void *data)
-
- int OAHash::remove(char *key)
- {
-- register unsigned int p, i;
-+ unsigned int p, i;
-
- for (i = 0; i < positions; ++i)
- {
-@@ -108,7 +108,7 @@ int OAHash::remove(char *key)
-
- void *OAHash::lookup(char *key)
- {
-- register unsigned int p, i;
-+ unsigned int p, i;
-
- for (i = 0; i < positions; ++i)
- {