aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2022-10-27 15:20:15 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2022-10-27 15:20:42 +0000
commit04208eb4021b6be557c1cbf5d3ddef54ba42311d (patch)
tree6775dfcd267bfaf9e0af6af1b61c6beee9c7aae0
parentd86c500210bf278c95aba3a224f91fb5f9c42fb1 (diff)
downloadports-04208eb4021b6be557c1cbf5d3ddef54ba42311d.tar.gz
ports-04208eb4021b6be557c1cbf5d3ddef54ba42311d.zip
net/mosh: Update to 1.4.0
-rw-r--r--net/mosh/Makefile13
-rw-r--r--net/mosh/distinfo6
-rw-r--r--net/mosh/files/patch-src_network_network.cc11
3 files changed, 10 insertions, 20 deletions
diff --git a/net/mosh/Makefile b/net/mosh/Makefile
index 662854311e9c..5a5e8e303d84 100644
--- a/net/mosh/Makefile
+++ b/net/mosh/Makefile
@@ -1,9 +1,6 @@
PORTNAME= mosh
-PORTVERSION= 1.3.2
-PORTREVISION= 20
+PORTVERSION= 1.4.0
CATEGORIES= net
-MASTER_SITES= https://mosh.org/ \
- ZI
MAINTAINER= zi@FreeBSD.org
COMMENT= Mobile terminal that supports intermittent connectivity
@@ -13,15 +10,19 @@ LICENSE= GPLv3
LIB_DEPENDS= libprotobuf.so:devel/protobuf
+USES= autoreconf compiler:c++11-lang ncurses perl5 pkgconfig ssl
USE_PERL5= run
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-utempter --without-ncurses
-CONFIGURE_ENV+= CRYPTO_CFLAGS="-I${OPENSSLINC}" CRYPTO_LIBS="-L${OPENSSLLIB} -lssl -lcrypto" \
+CONFIGURE_ENV+= OpenSSL_CFLAGS="-I${OPENSSLINC}" OpenSSL_LIBS="-L${OPENSSLLIB} -lssl -lcrypto" \
TINFO_CFLAGS="-I/usr/include"
INSTALL_TARGET= install-strip
-USES= compiler:c++11-lang ncurses perl5 pkgconfig ssl
USE_CXXSTD= c++11
+USE_GITHUB= yes
+GH_ACCOUNT= mobile-shell
+GH_TAGNAME= ${PORTNAME}-${PORTVERSION}
+
CONFLICTS_INSTALL= mosh-0.[2-9].*
PLIST_FILES= bin/mosh bin/mosh-server bin/mosh-client \
diff --git a/net/mosh/distinfo b/net/mosh/distinfo
index de00ad4bc295..72692276e999 100644
--- a/net/mosh/distinfo
+++ b/net/mosh/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1500858600
-SHA256 (mosh-1.3.2.tar.gz) = da600573dfa827d88ce114e0fed30210689381bbdcff543c931e4d6a2e851216
-SIZE (mosh-1.3.2.tar.gz) = 359574
+TIMESTAMP = 1666882635
+SHA256 (mobile-shell-mosh-1.4.0-mosh-1.4.0_GH0.tar.gz) = ae581fbddf038730af9eee4d319a483288395a0722d0c94c7efb7fdbdbb0dbac
+SIZE (mobile-shell-mosh-1.4.0-mosh-1.4.0_GH0.tar.gz) = 229899
diff --git a/net/mosh/files/patch-src_network_network.cc b/net/mosh/files/patch-src_network_network.cc
deleted file mode 100644
index e4c2388b6b69..000000000000
--- a/net/mosh/files/patch-src_network_network.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/network/network.cc.orig 2017-07-22 21:14:53 UTC
-+++ src/network/network.cc
-@@ -335,7 +335,7 @@ bool Connection::try_bind( const char *a
- }
- }
-
-- if ( bind( sock(), &local_addr.sa, local_addr_len ) == 0 ) {
-+ if ( ::bind( sock(), &local_addr.sa, local_addr_len ) == 0 ) {
- set_MTU( local_addr.sa.sa_family );
- return true;
- } else if ( i == search_high ) { /* last port to search */