aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Druzenko <vvd@FreeBSD.org>2024-06-22 21:47:07 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2024-06-22 21:47:07 +0000
commit044c1da998cd0ade9bd208c6db68826648c6f871 (patch)
treee805f53d429ac2daf1138976b6e4c4bbabe968a9
parent47a9b39d5342f3db825e1f0531f8bf24f6bc0588 (diff)
downloadports-044c1da998cd0ade9bd208c6db68826648c6f871.tar.gz
ports-044c1da998cd0ade9bd208c6db68826648c6f871.zip
devel/libexplain: fix build with llvm15+ from base
While here remove unnecessary GNU_CONFIGURE_MANPREFIX.
-rw-r--r--devel/libexplain/Makefile12
-rw-r--r--devel/libexplain/distinfo1
-rw-r--r--devel/libexplain/files/patch-libexplain_buffer_errno_acl__set__file.c11
3 files changed, 14 insertions, 10 deletions
diff --git a/devel/libexplain/Makefile b/devel/libexplain/Makefile
index faa396858b52..2c98901605e8 100644
--- a/devel/libexplain/Makefile
+++ b/devel/libexplain/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libexplain
PORTVERSION= 1.3.${PATCHLEVEL}
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION:R}
DISTNAME= ${PORTNAME}-${PORTVERSION:R}
@@ -13,7 +13,6 @@ LICENSE= LGPL3+
LICENSE_FILE= ${WRKSRC}/LICENSE
DEPRECATED= Upstream last release was in 2014
-#BROKEN_FreeBSD_14= Build fails with lots of error on llvm15
BUILD_DEPENDS= gsed:textproc/gsed
RUN_DEPENDS= lsof:sysutils/lsof
@@ -22,20 +21,13 @@ USES= bison gettext ghostscript:build gmake groff iconv libtool:build localbase
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
CONFIGURE_ENV= ac_cv_header_linux_kd_h=no
+CFLAGS+= -Wno-error=int-conversion
OPTIONS_DEFINE= DOCS
PATCHLEVEL= D012
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
-USES+= llvm:max=14
-MAKE_JOBS_UNSAFE= yes
-.endif
-
.include <bsd.port.pre.mk>
.if empty(ICONV_LIB)
diff --git a/devel/libexplain/distinfo b/devel/libexplain/distinfo
index 18d8861afa77..aa3d9312a9f4 100644
--- a/devel/libexplain/distinfo
+++ b/devel/libexplain/distinfo
@@ -1,2 +1,3 @@
+TIMESTAMP = 1719082732
SHA256 (libexplain-1.3.tar.gz) = ef36c52795d737a189a139d527e78d3beafdbd017cb3cf71df47027e8beb1215
SIZE (libexplain-1.3.tar.gz) = 4762371
diff --git a/devel/libexplain/files/patch-libexplain_buffer_errno_acl__set__file.c b/devel/libexplain/files/patch-libexplain_buffer_errno_acl__set__file.c
new file mode 100644
index 000000000000..8a46541b4e04
--- /dev/null
+++ b/devel/libexplain/files/patch-libexplain_buffer_errno_acl__set__file.c
@@ -0,0 +1,11 @@
+--- libexplain/buffer/errno/acl_set_file.c.orig 2013-12-08 01:47:33 UTC
++++ libexplain/buffer/errno/acl_set_file.c
+@@ -195,7 +195,7 @@ explain_buffer_errno_acl_set_file_explanation(explain_
+ #ifdef _PC_ACL_PATH_MAX
+ if (explain_option_dialect_specific())
+ {
+- explain_string_buffer_printf(" (%d > %d)", num, max);
++ explain_string_buffer_printf(sb, " (%d > %d)", num, max);
+ }
+ #endif
+ break;