aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2024-05-20 07:31:34 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2024-05-20 08:26:30 +0000
commit04d1c509299c344b6492dc4c691ad8cd29e3efff (patch)
tree5208557a8b3918075ffff12309e2fd0f78c50bb0
parent441d96b9e9c6f385d6a4ef4d7ce1131ff9f2587c (diff)
downloadports-04d1c509299c344b6492dc4c691ad8cd29e3efff.tar.gz
ports-04d1c509299c344b6492dc4c691ad8cd29e3efff.zip
net/bredbandskollen: Fix tests
Upstream uses googletests to run tests that requires at least c++14 standard. Apply upstream patch that upgrades from c++11 -> c++14. See also: https://github.com/dotse/bbk/pull/16
-rw-r--r--net/bredbandskollen/Makefile7
-rw-r--r--net/bredbandskollen/distinfo4
2 files changed, 8 insertions, 3 deletions
diff --git a/net/bredbandskollen/Makefile b/net/bredbandskollen/Makefile
index 238667cd546c..b6c13b25e228 100644
--- a/net/bredbandskollen/Makefile
+++ b/net/bredbandskollen/Makefile
@@ -1,8 +1,12 @@
PORTNAME= bredbandskollen
DISTVERSIONPREFIX= BBK_CLI_
DISTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= net
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES= 1a5f2870b48c3ec85be1c45c397992a218b0af77.patch:-p1 # Switch to c++14, fix tests; https://github.com/dotse/bbk/issues/14
+
MAINTAINER= eduardo@FreeBSD.org
COMMENT= Command line tool to check internet connection speed
WWW= https://github.com/dotse/bbk
@@ -12,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/src/LICENSE
TEST_DEPENDS= googletest>0:devel/googletest
-USES= gmake
+USES= gmake localbase
USE_GITHUB= yes
GH_ACCOUNT= dotse
GH_PROJECT= bbk
@@ -35,7 +39,6 @@ do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/cli ${STAGEDIR}/${PREFIX}/bin/bbk_cli
${LN} -sf bbk_cli ${STAGEDIR}/${PREFIX}/bin/bredbandskollen
-# testunit requires --std>=c++14, https://github.com/dotse/bbk/issues/14
do-test:
cd ${WRKSRC}/src/test && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} test
diff --git a/net/bredbandskollen/distinfo b/net/bredbandskollen/distinfo
index 91a5c4a0fd73..cc7ddc640d86 100644
--- a/net/bredbandskollen/distinfo
+++ b/net/bredbandskollen/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1709322856
+TIMESTAMP = 1716188314
SHA256 (dotse-bbk-BBK_CLI_1.2_GH0.tar.gz) = dff38d1226844642891afcd869bfce2b9d0414c9507bacf156fb5849ab2ae8c5
SIZE (dotse-bbk-BBK_CLI_1.2_GH0.tar.gz) = 174352
+SHA256 (1a5f2870b48c3ec85be1c45c397992a218b0af77.patch) = 6366f228445d0f65c8754c1809fb4f0602aa384a9c8611ac18e8639c376330ba
+SIZE (1a5f2870b48c3ec85be1c45c397992a218b0af77.patch) = 4441