aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-16 04:41:05 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-16 05:34:37 +0000
commit04ef5f7e604be3c382951983e9d96d6bc046997f (patch)
treea63031a80c51321e497868d668a298423e3e3612
parent61d8e50a2a94b2785a06f48936b9043a0a1051fc (diff)
downloadports-04ef5f7e604be3c382951983e9d96d6bc046997f.tar.gz
ports-04ef5f7e604be3c382951983e9d96d6bc046997f.zip
sysutils/bareos21-*: Fix build on 14
- Utilize USES=localbase - Utilize OPTIONSNG where possible Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--sysutils/bareos21-server/Makefile34
1 files changed, 18 insertions, 16 deletions
diff --git a/sysutils/bareos21-server/Makefile b/sysutils/bareos21-server/Makefile
index 29feacab8afa..13992272e8a7 100644
--- a/sysutils/bareos21-server/Makefile
+++ b/sysutils/bareos21-server/Makefile
@@ -18,7 +18,7 @@ CONFLICTS?= bareos-server bareos20-server bareos19-server bareos18-server
LIB_DEPENDS+= liblzo2.so:archivers/lzo2 \
libjansson.so:devel/jansson
-USES+= cmake compiler:c++11-lang cpe localbase perl5 pkgconfig readline \
+USES+= cmake compiler:c++11-lang cpe localbase:ldflags perl5 pkgconfig readline \
shebangfix
USE_GITHUB= yes
USE_PERL5= run
@@ -33,8 +33,7 @@ SHEBANG_LANG= perl
SHEBANG_FILES= ${WRKSRC}/core/src/cats/make_catalog_backup.pl.in
CFLAGS+= -Wno-error
-CPPFLAGS+= -I${LOCALBASE}/readline -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/readline
OPTIONS_DEFAULT= OPENSSL
OPTIONS_SINGLE= CRYPTO
@@ -172,22 +171,15 @@ CMAKE_ARGS+= -Dbuild-dird=ON \
-Dbuild_client_only=OFF
# Server default database
+MTX_RUN_DEPENDS= ${LOCALBASE}/sbin/mtx:misc/mtx
+MYSQL_VARS= DBTYPE=mysql
+MYSQL_SUB_LIST= REQ_MYSQL=mysql REQ_PGSQL=""
PGSQL_CMAKE_ON= -Dpostgresql=ON
PGSQL_USES= pgsql
+PGSQL_VARS= DBTYPE=postgresql
+PGSQL_SUB_LIST= REQ_MYSQL="" REQ_PGSQL=postgresql
+SQLITE3_VARS= DBTYPE=sqlite3
-MTX_RUN_DEPENDS= ${LOCALBASE}/sbin/mtx:misc/mtx
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMYSQL}
-DBTYPE= mysql
-SUB_LIST+= REQ_MYSQL=mysql REQ_PGSQL=""
-.elif ${PORT_OPTIONS:MSQLITE3}
-DBTYPE= sqlite3
-.else
-DBTYPE= postgresql
-SUB_LIST+= REQ_MYSQL="" REQ_PGSQL=postgresql
-.endif
PLIST_SUB+= DBTYPE=${DBTYPE}
.endif
@@ -238,4 +230,14 @@ post-install:
.else
.include "${MASTERDIR}/Makefile.common"
.endif # -client and -server are defined
+
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+USES+= llvm:max=15
+CC= clang${LLVM_VERSION}
+CPP= clang-cpp${LLVM_VERSION}
+CXX= clang++${LLVM_VERSION}
+.endif
+
.include <bsd.port.mk>