aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2022-04-19 08:04:45 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2022-04-19 08:04:45 +0000
commit0524bb607cfcc51b670796ab3232f690fd6ae9de (patch)
tree9773085e082d1fad46db2dae3d92d47aa86463de
parent6a9ffb1def637dff98c61432f10b610c7aecfedb (diff)
downloadports-0524bb607cfcc51b670796ab3232f690fd6ae9de.tar.gz
ports-0524bb607cfcc51b670796ab3232f690fd6ae9de.zip
net/unison: Try to fix build failure due to race condition in Makefile
PR: 263067 MFH: 2022Q2
-rw-r--r--net/unison/files/patch-Makefile.OCaml19
1 files changed, 15 insertions, 4 deletions
diff --git a/net/unison/files/patch-Makefile.OCaml b/net/unison/files/patch-Makefile.OCaml
index 45859e189c5a..503906115d6e 100644
--- a/net/unison/files/patch-Makefile.OCaml
+++ b/net/unison/files/patch-Makefile.OCaml
@@ -1,6 +1,6 @@
---- Makefile.OCaml.orig 2021-06-23 14:30:30 UTC
+--- Makefile.OCaml.orig 2022-03-12 16:24:03 UTC
+++ Makefile.OCaml
-@@ -34,7 +34,11 @@ ifeq ($(shell uname),OpenBSD)
+@@ -31,7 +31,11 @@ ifeq ($(shell uname),NetBSD)
else
ifeq ($(shell uname),NetBSD)
OSARCH=NetBSD
@@ -12,7 +12,7 @@
ifeq ($(shell uname),Linux)
OSARCH=Linux
endif
-@@ -290,6 +294,11 @@ ifeq ($(OSARCH),Linux)
+@@ -315,6 +319,11 @@ endif
INCLFLAGS+=-I fsmonitor -I fsmonitor/linux
endif
@@ -24,7 +24,18 @@
ifeq ($(OSARCH),solaris)
-include fsmonitor/solaris/Makefile src/fsmonitor/solaris/Makefile
INCLFLAGS+=-I fsmonitor -I fsmonitor/solaris
-@@ -432,7 +441,7 @@ fswatch.cmi : ubase/prefs.cmi
+@@ -442,6 +451,10 @@ win32rc/unison.res.lib: win32rc/unison.rc win32rc/U.ic
+ -$(RM) $@
+ ocamllex $<
+
++compat%.cmi: compat%.mli
++ @echo "$(CAMLC): $< ---> $@"
++ $(CAMLC) $(CAMLFLAGS) $(COMPATCAMLFLAGS) -c $(CWD)/$<
++
+ %.cmi : %.mli
+ @echo "$(CAMLC): $< ---> $@"
+ $(CAMLC) $(CAMLFLAGS) $(COMPATCAMLFLAGS) -c $(CWD)/$<
+@@ -466,7 +479,7 @@ compat%.cmx: compat%.ml
%.o %.obj: %.c
@echo "$(CAMLC): $< ---> $@"