aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2024-02-09 12:22:57 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2024-02-11 11:48:53 +0000
commit054c6d9fdca47dda2bc2b97c540cc459e90a5190 (patch)
tree6c9397d24e96c2aec64ea4b09329211f77a97074
parented20da9d374b6d4596c3bfd27af19546ed7a60f4 (diff)
downloadports-054c6d9fdca47dda2bc2b97c540cc459e90a5190.tar.gz
ports-054c6d9fdca47dda2bc2b97c540cc459e90a5190.zip
games/vkquake: fix build on 32-bits
./atomics.h:201:9: error: large atomic operation may incur significant performance penalty; the access size (8 bytes) exceeds the max lock-free size (4 bytes) [-Werror,-Watomic-alignment] return atomic_fetch_add (atomic, value); ^ /usr/include/stdatomic.h:354:2: note: expanded from macro 'atomic_fetch_add' atomic_fetch_add_explicit(object, operand, memory_order_seq_cst) ^ /usr/include/stdatomic.h:247:2: note: expanded from macro 'atomic_fetch_add_explicit' __c11_atomic_fetch_add(object, operand, order)
-rw-r--r--games/vkquake/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/vkquake/Makefile b/games/vkquake/Makefile
index eb07ab9109c7..f225c2380fb2 100644
--- a/games/vkquake/Makefile
+++ b/games/vkquake/Makefile
@@ -28,7 +28,7 @@ ALL_TARGET= # empty
.include "${.CURDIR}/../quake-data/Makefile.include"
-CFLAGS+= -DDATADIR='\"${Q1DIR}\"'
+CFLAGS+= -DDATADIR='\"${Q1DIR}\"' -Wno-error=atomic-alignment
OPTIONS_DEFINE= USERDIRS WAVE FLAC MP3 VORBIS # OPUS
OPTIONS_RADIO= MODPLAYER