aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-09-05 08:11:33 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-09-05 08:15:51 +0000
commit05be3d3a279ef387900a0ab4fad92fe8da1d0a7d (patch)
tree493edbf63cfa4a0a7ea34bc036f042d922ca8083
parent738f9f22ad1f1b4a65c6c4a068b21c63f0877d6c (diff)
downloadports-05be3d3a279ef387900a0ab4fad92fe8da1d0a7d.tar.gz
ports-05be3d3a279ef387900a0ab4fad92fe8da1d0a7d.zip
math/mfem: Fix SUPERLU option and make it default
-rw-r--r--math/mfem/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/math/mfem/Makefile b/math/mfem/Makefile
index 4f1d71b3f041..3a449d8f02e1 100644
--- a/math/mfem/Makefile
+++ b/math/mfem/Makefile
@@ -1,7 +1,7 @@
PORTNAME= mfem
DISTVERSIONPREFIX= v
DISTVERSION= 4.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -20,7 +20,7 @@ CMAKE_TESTING_ON= MFEM_ENABLE_TESTING # tests are broken, see https://github.com
OPTIONS_DEFINE= SUPERLU
OPTIONS_SINGLE= MPI
OPTIONS_SINGLE_MPI= NOMPI MPICH OPENMPI
-OPTIONS_DEFAULT= MPICH # should be the same choice as in science/hypre
+OPTIONS_DEFAULT= MPICH SUPERLU # should be the same MPI choice as in science/hypre
OPTIONS_SUB= yes
NOMPI_DESC= Build without parallel processing support
@@ -39,6 +39,10 @@ OPENMPI_LIB_DEPENDS= libHYPRE.so:science/hypre \
SUPERLU_DESC= Enable SuperLU use
SUPERLU_CMAKE_BOOL= MFEM_USE_SUPERLU
SUPERLU_CMAKE_ON= -DSuperLUDist_DIR=${LOCALBASE} -DSuperLUDist_INCLUDE_DIRS=${LOCALBASE}/include/superlu
-SUPERLU_BROKEN= build fails, see https://github.com/mfem/mfem/issues/3171
+SUPERLU_LIB_DEPENDS= libsuperlu_dist.so:math/superlu-dist
+SUPERLU_LDFLAGS= -L${LOCALBASE}/lib -lsuperlu_dist # workaround for https://github.com/mfem/mfem/issues/3171#issuecomment-1236591028
+
+post-install-SUPERLU-on: # workaround for https://github.com/mfem/mfem/issues/3191
+ @${REINPLACE_CMD} -e 's|;${LOCALBASE}/include/superlu||' ${STAGEDIR}${PREFIX}/lib/cmake/mfem/MFEMConfig.cmake
.include <bsd.port.mk>