aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-02-28 09:34:55 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-02-28 12:46:14 +0000
commit061707677a4c6e26b83046e925e8fa37e8e4f09b (patch)
treea8a2548f0ddb1e7e156c292fa1713fe0264bc39b
parent8d7611883fab837793747d7c3d0a1b56ec0a567a (diff)
downloadports-061707677a4c6e26b83046e925e8fa37e8e4f09b.tar.gz
ports-061707677a4c6e26b83046e925e8fa37e8e4f09b.zip
devel/py-l18n: Update to 2021.3
- Fix typo in b400db1f3274a5d4fccc0079d515999f7272c702 Changes: https://github.com/tkhyn/l18n/blob/develop/CHANGES.rst
-rw-r--r--devel/py-l18n/Makefile4
-rw-r--r--devel/py-l18n/distinfo6
-rw-r--r--devel/py-l18n/files/patch-setup.py27
3 files changed, 23 insertions, 14 deletions
diff --git a/devel/py-l18n/Makefile b/devel/py-l18n/Makefile
index ac90e6a9913d..d8fd33141212 100644
--- a/devel/py-l18n/Makefile
+++ b/devel/py-l18n/Makefile
@@ -1,7 +1,7 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= l18n
-PORTVERSION= 2020.6.1
+PORTVERSION= 2021.3
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +12,7 @@ COMMENT= Internationalization for pytz timezones and territories
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>=2020.1,1,1:devel/py-pytz@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>=2020.1,1:devel/py-pytz@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
USES= python:3.6+
diff --git a/devel/py-l18n/distinfo b/devel/py-l18n/distinfo
index 174a75e932cb..55b0eaef7e17 100644
--- a/devel/py-l18n/distinfo
+++ b/devel/py-l18n/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1605426415
-SHA256 (l18n-2020.6.1.tar.gz) = ea7a65b2f0935b14601a3295f2c5e5e8b54126dd1e6a7fef4e44d2b8dd5b695a
-SIZE (l18n-2020.6.1.tar.gz) = 50557
+TIMESTAMP = 1643971064
+SHA256 (l18n-2021.3.tar.gz) = 1956e890d673d17135cc20913253c154f6bc1c00266c22b7d503cc1a5a42d848
+SIZE (l18n-2021.3.tar.gz) = 50712
diff --git a/devel/py-l18n/files/patch-setup.py b/devel/py-l18n/files/patch-setup.py
index 739eb79fa71b..7684de49af78 100644
--- a/devel/py-l18n/files/patch-setup.py
+++ b/devel/py-l18n/files/patch-setup.py
@@ -1,11 +1,20 @@
---- setup.py.orig 2020-10-31 03:58:31 UTC
+--- setup.py.orig 2021-11-12 09:24:24 UTC
+++ setup.py
-@@ -69,7 +69,7 @@ class PredistBuild(object):
- log.info('translation files built successfully')
+@@ -30,17 +30,8 @@ DEV_STATUS = {'pre': '2 - Pre-Alpha',
+ CMD_PACKAGES = {
+ 'sdist': 'setuptools.command',
+ 'bdist': 'distutils.command',
+- 'bdist_wheel': 'wheel',
+ 'bdist_egg': 'setuptools.command',
+- 'bdist_rpm': 'setuptools.command',
+ }
+-
+-try:
+- from setuptools.command import bdist_wininst
+- CMD_PACKAGES['bdist_wininst'] = 'setuptools.command'
+-except ImportError:
+- # python > 3.10
+- pass
- cmd_classes = {}
--for cmd in ('sdist', 'bdist', 'bdist_egg', 'bdist_rpm', 'bdist_wininst'):
-+for cmd in ('sdist', 'bdist', 'bdist_egg'):
- try:
- cmd_module = getattr(__import__('setuptools.command', fromlist=[cmd]),
- cmd)
+
+ class PredistBuild(object):